Bug 492028 - Bigpond Fedora repository appears to be broken
Bigpond Fedora repository appears to be broken
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: mirrormanager (Show other bugs)
10
All Linux
low Severity low
: ---
: ---
Assigned To: Matt Domsch
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-24 20:37 EDT by David Cartwright
Modified: 2014-01-21 18:08 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-29 11:07:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Cartwright 2009-03-24 20:37:10 EDT
Description of problem:
For months have been seeing "url open error timed out" errors on yum updates due to lack of responses from the Bigpond repositories, e.g.
http://ga13.files.bigpond.com:4040/

It appears that the Telstra Bigpond repos are consistently given first priority by yum, however invariably the repos fail, causing yum responsiveness to appear very poor.


Version-Release number of selected component (if applicable):


How reproducible:
Happening consistently over months on more than ten systems.


Steps to Reproduce:
1. Try to update or install via yum;
2.
3.
  
Actual results:
Long delay in response and receive an error message "url open error timed out". Yum then continues process via a different repo source.

Expected results:
Problems with lack of response from a specific yum repo would be sporadic rather than a consistent problem over many months.


Additional info:
Comment 1 James Antill 2009-03-25 01:14:07 EDT
Are you using yum-fastestmirror? What does your mirrorlist say -- /var/cache/yum/*/mirrorlist.txt

 It's possible that "bigpond" has configured something based on IP address saying that they are a local repo. for your IPs. However yum itself isn't doing this.
Comment 2 David Cartwright 2009-03-25 01:40:05 EDT
Hi James,

The reason I entered this as an issue is as follows:

1. Telstra Bigpond is Australia's largest ISP;

2. The fact that I have been seeing the same problem from various F9 and F10 installations at multiple sites suggests to me that I won't be the only Australian user seeing this problem;

3. Yes I have tried yum-fastestmirror;

4. My concern is that it "appears" that the Bigpond repositories are broken and therefore most Fedora users in Australia are likely experiencing the same problem. This therefore reflects poorly on Fedora and yum.

Hence, my main concern is that if the Bigpond repo are broken, they should be removed from the mirror list, thereby improving the performance of yum for Australian users. Alternatively, whoever coordinates with Telstra Bigpond should work with them to find out why their repos appear to have been broken for at least the last few months.

btw, here is a sample mirrorlist.txt from one of the servers in question:
# repo = fedora-9 arch = x86_64 country = AU
http://ga13.files.bigpond.com:4040/fedora/linux/releases/9/Everything/x86_64/os/
http://ga14.files.bigpond.com:4040/fedora/linux/releases/9/Everything/x86_64/os/
http://mirror.aarnet.edu.au/pub/fedora/linux/releases/9/Everything/x86_64/os/
http://ftp.iinet.net.au/pub/fedora/linux/releases/9/Everything/x86_64/os/
http://mirror.internode.on.net/pub/fedora/linux/releases/9/Everything/x86_64/os/
http://ringtail.its.monash.edu.au/pub/fedora/linux/releases/9/Everything/x86_64/os/
http://mirror.optus.net/fedora/linux/releases/9/Everything/x86_64/os/
Comment 3 James Antill 2009-03-25 02:43:22 EDT
Ok, passing it to matt. I assume he can remove them, or look into monitoring them or something.
Not sure what the real processes is ... sorry matt.
Comment 4 Matt Domsch 2009-03-25 09:05:14 EDT
I've sent a note to the mirror admin for the bigpond mirrors, and await his reply.  I've also checked the MM crawler logs, and don't see anything unusual - they both seem to be responsive to all the HTTP HEAD requests being thrown at them during the month of March.
Comment 5 Trent 2009-03-27 11:08:47 EDT
I am sorry to hear you are having problems accessing Bigpond's Fedora mirrors. 

We have not heard of other users experiencing your problems. If you are able to provide some more information we will investigate this further.

When you experience these problems, from the same host are you able to access and/or browse http://ga13.files.bigpond.com:4040/fedora/linux/ or http://ga14.files.bigpond.com:4040/fedora/linux/ via Firefox or lynx?

Are you able to include a layer 4 traceroute to ga13.files.bigpond.com:4040 from the effected hosts? (lft is in the rpmforge repo).

Specific source IPs and times would be extremely useful for parsing our access/error logs. 

Thanks,
--
Trent
Comment 6 David Cartwright 2009-03-28 20:20:36 EDT
I have tracked down that the problem is related to the non-standard TCP port Bigpond uses for these repositories.

What threw me was that I was seeing from multiple sites via different ISPs.

However all the sites use the same managed firewall system that has rules blocking non-standard TCP ports for initial HTTP traffic, e.g. the firewalls are blocking the outgoing requests to port 4040.

I will request a rule update for all the firewalls to allow outgoing HTTP requests to Bigpond on port 4040.

I guess not too many sites in Australia use strict outbound firewall rules!

Thanks to all for helping me identify the issue.

cheers ... david

Note You need to log in before you can comment on or make changes to this bug.