Bug 49206 - %doc entry in spec file erroneous
Summary: %doc entry in spec file erroneous
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: librep (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-16 20:55 UTC by Joachim Frieben
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 21:10:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Joachim Frieben 2001-07-16 20:55:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Description of problem:
Due to a wrong %doc line in the spec file, the TODO file is not included 
into the binary RPM. rpm* complains during build process.

How reproducible:
Always

Steps to Reproduce:
1. Install SRPM, have a look at librep.spec. Rebuild RPM.

Actual Results:  rpm* complains at the end of the build process that it 
cannot stat the file doc/TODO, which is not surprising since doc/ does not 
exist in current versions of librep.

Expected Results:  Build process of librep terminates without error 
message.

Additional info:

%doc NEWS README etc/TODO

  must rather be:

%doc NEWS README TODO

With this modification everything goes well.

Comment 1 Havoc Pennington 2001-07-16 22:09:23 UTC
Fixed in latest tree


Note You need to log in before you can comment on or make changes to this bug.