Bug 492106 - LVM error anac 11.5.0.36
LVM error anac 11.5.0.36
Status: CLOSED DUPLICATE of bug 491997
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:4cdaf94ee2f99aa63...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 08:29 EDT by A.J. Werkman
Modified: 2009-03-25 09:59 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 09:59:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (84.58 KB, text/plain)
2009-03-25 08:29 EDT, A.J. Werkman
no flags Details

  None (edit)
Description A.J. Werkman 2009-03-25 08:29:03 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.36 exception report
Traceback (most recent call first):
  File "/usr/lib/python2.6/site-packages/parted/disk.py", line 194, in removePartition
    if self.__disk.remove_partition(partition.getPedPartition()):
  File "/usr/lib/anaconda/storage/devicetree.py", line 697, in _removeDevice
    dev.disk.partedDisk.removePartition(dev.partedPartition)
  File "/usr/lib/anaconda/storage/devicetree.py", line 731, in registerAction
    self._removeDevice(action.device)
  File "/usr/lib/anaconda/storage/__init__.py", line 600, in destroyDevice
    self.devicetree.registerAction(action)
  File "/usr/lib/anaconda/storage/partitioning.py", line 332, in clearPartitions
    storage.destroyDevice(part)
  File "/usr/lib/anaconda/storage/partitioning.py", line 170, in doAutoPartition
    clearPartitions(anaconda.id.storage)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/text.py", line 697, in run
    anaconda.dispatch.gotoNext()
  File "/usr/bin/anaconda", line 1026, in <module>
    anaconda.intf.run(anaconda)
PartitionException: Attempting to remove a partition that is not owned by any disk.
Comment 1 A.J. Werkman 2009-03-25 08:29:10 EDT
Created attachment 336631 [details]
Attached traceback automatically from anaconda.
Comment 2 A.J. Werkman 2009-03-25 08:53:02 EDT
Anaconda 11.5.0.36 text install.

I got this exception on a system with two harddisks where there was already a partitioning scheme on the disks.

When I zeroed out the first 10 Mb of data on the disks (dd if=/dev/zero of=/dev/sd[a,b]) I could not reproduce the error and installation finished well.
Comment 3 Chris Lumens 2009-03-25 09:59:18 EDT

*** This bug has been marked as a duplicate of bug 491997 ***

Note You need to log in before you can comment on or make changes to this bug.