Bug 49211 - RPM --nodpes Flag Broken?
Summary: RPM --nodpes Flag Broken?
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-16 23:11 UTC by Thornton Prime
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 23:11:36 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Thornton Prime 2001-07-16 23:11:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.6-2 i686; Nav)

Description of problem:
Cannot perform an upgrade or install with a failed dependency despite
specifying --nodeps flag.

How reproducible:
Always

Steps to Reproduce:
1. rpm -Uvh --nodpeps package-with-unsatisfied-dependencies
2.
3.
	

Actual Results:  rpm -ivh --nodeps
RPMS/noarch/xerces-j-manual-1.4.1-1.noarch.rpm
error: failed dependencies:
        webserver is needed by xerces-j-manual-1.4.1-1



Expected Results:  Install it anyway.

Additional info:

Comment 1 Jeff Johnson 2001-07-17 17:02:13 UTC
FIxed in rpm-4.0.3-0.72 (at least).


Note You need to log in before you can comment on or make changes to this bug.