Bug 492119 - Install counts wrong number of packages
Install counts wrong number of packages
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 09:26 EDT by Prarit Bhargava
Modified: 2009-07-28 16:33 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-28 16:33:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prarit Bhargava 2009-03-25 09:26:38 EDT
Description of problem:

When installing RHEL5 Server U3 in RHTS, the number of installed packages is output.  At the end of the installs, however, I see:

Installing NetworkManager-0.7.0-3.el5...  Done [693/709]
Installing NetworkManager-glib-0.7.0-3.el5...  Done [694/709]
Installing NetworkManager-0.7.0-3.el5...  Done [695/709]
Installing xulrunner-1.9.0.5-1.el5_2...  Done [696/709]
Installing libbonoboui-2.16.0-1.fc6...  Done [697/709]
Installing gnome-mount-0.5-3.el5...  Done [698/709]
Installing libgnome-2.16.0-6.el5...  Done [699/709]
Installing libgnomeui-2.16.0-5.el5...  Done [700/709]
Installing gnome-vfs2-2.16.2-4.el5...  Done [701/709]
Installing xulrunner-1.9.0.5-1.el5_2...  Done [702/709]
Installing xulrunner-devel-1.9.0.5-1.el5_2...  Done [703/709]
Installing xulrunner-devel-1.9.0.5-1.el5_2...  Done [704/709]
Installing gnome-python2-2.16.0-1.fc6...  Done [705/709]
Installing gnome-python2-gconf-2.16.0-1.fc6...  Done [706/709]
Installing gnome-python2-bonobo-2.16.0-1.fc6...  Done [707/709]
Installing gnome-python2-gnomevfs-2.16.0-1.fc6...  Done [708/709]
Installing dogtail-0.6.1-2.el5...  Done [709/709]
Installing Deployment_Guide-en-US-5.2-11...  Done [710/709]


Version-Release number of selected component (if applicable): anaconda-11.1.2.168-1


How reproducible: 100%.


Steps to Reproduce:
1. Install RHEL5 Server U3 via RHTS
2. Watch console during install
  
Actual results: See above output.


Expected results: Install should count the right number of packages.


Additional info: I've seen this on a few different systems so I think it is a generic problem.
Comment 1 Chris Lumens 2009-07-28 16:33:16 EDT
The count is off likely because the kernel gets counted once for the package and once for the scriptlet.  We've seen similar things with the kernel package in Fedora.  Anyway, this isn't really a high priority item and is unlikely to ever see a fix in a RHEL update.  Closing to set expectations.

Note You need to log in before you can comment on or make changes to this bug.