Bug 492121 - Package perl-Crypt-RIPEMD160 is not Required by anything on Satellite 5.3.0, we might want to not ship it
Package perl-Crypt-RIPEMD160 is not Required by anything on Satellite 5.3.0, ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Steve Salevan
:
Depends On:
Blocks: 463876
  Show dependency treegraph
 
Reported: 2009-03-25 09:39 EDT by Jan Pazdziora
Modified: 2009-09-10 14:54 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:54:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pazdziora 2009-03-25 09:39:08 EDT
Description of problem:

Package perl-Crypt-RIPEMD160 is not Required by anything on Satellite 5.3.0, we might want to not ship it.

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090323.0 on i386
perl-Crypt-RIPEMD160-0.04-15.el5.i386.rpm

How reproducible:

Deterministic.

Steps to Reproduce:
1. Install Satellite 5.3.0.
2. Run rpm -q perl-Crypt-RIPEMD160, check that package perl-Crypt-RIPEMD160 is installed.
3. Run rpm -e perl-Crypt-RIPEMD160.
4. Run rpm -q perl-Crypt-RIPEMD160 again, check that it's now been removed.
  
Actual results:

Package perl-Crypt-RIPEMD160 is installed but it is not required by anything in the Satellite, so it can safely be removed.

Expected results:

Either the package should be Required by some other package, or it should not be on the compose.

Additional info:

Note that the perl modules also has some licencing issues, that's one of the reasons we no longer ship it with Spacewalk nor push it to Fedora -- bug 452453.
Comment 1 Jan Pazdziora 2009-03-25 09:44:29 EDT
On Satellite 5.2.0, perl-Crypt-RIPEMD160 was neede by perl-Crypt-OpenPGP but we no longer ship nor require perl-Crypt-OpenPGP.
Comment 2 Brandon Perkins 2009-03-26 12:38:15 EDT
Jesus, please enter the RT ticket for this and follow it through to completion, then modify the bug.
Comment 3 Shannon Hughes 2009-04-01 13:44:07 EDT
did a quick verity on codebase and entered rt ticket #38672. modifying bug.
Comment 4 Shannon Hughes 2009-04-06 11:09:20 EDT
mass move to onqa
Comment 5 Steve Salevan 2009-04-08 12:19:30 EDT
# rpm -q perl-Crypt-RIPEMD160
package perl-Crypt-RIPEMD160 is not installed

Moving to VERIFIED.
Comment 6 Steve Salevan 2009-08-07 15:05:11 EDT
# rpm -q perl-Crypt-RIPEMD160
package perl-Crypt-RIPEMD160 is not installed

RELEASE_PENDING from 7/24 ISO.
Comment 7 Brandon Perkins 2009-09-10 14:54:15 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.