Bug 492138 - after the installation getting WEB TRACEBACK email each minute
after the installation getting WEB TRACEBACK email each minute
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
John Matthews
:
Depends On:
Blocks: 457079
  Show dependency treegraph
 
Reported: 2009-03-25 11:11 EDT by Jan Hutař
Modified: 2009-09-10 15:12 EDT (History)
4 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:12:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
few WEB TRACEBACK emails (40.00 KB, application/x-tar)
2009-03-25 11:11 EDT, Jan Hutař
no flags Details

  None (edit)
Description Jan Hutař 2009-03-25 11:11:34 EDT
Created attachment 336660 [details]
few WEB TRACEBACK emails

Description of problem:
After I install the Satellite, I'm getting "WEB TRACEBACK from <hostname>" each minute.


Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090323.0-x86_64


How reproducible:
always (?, currently on one s390x system)


Steps to Reproduce:
1. Install satellite


Actual results:
web tracebacks


Expected results:
no traceback emails


Additional info:
Discovered in http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=51962

Maybe these AVC's could be a reason:
time->Wed Mar 25 09:33:34 2009
type=SYSCALL msg=audit(1237988014.963:28): arch=80000016 syscall=125 success=no exit=-13 a0=3ffff9ae000 a1=1000 a2=1000007 a3=2000a06d5f8 items=0 ppid=1 pid=1857 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="osa-dispatcher" exe="/usr/bin/python" subj=system_u:system_r:osa_dispatcher_t:s0 key=(null)
type=AVC msg=audit(1237988014.963:28): avc:  denied  { execstack } for  pid=1857 comm="osa-dispatcher" scontext=system_u:system_r:osa_dispatcher_t:s0 tcontext=system_u:system_r:osa_dispatcher_t:s0 tclass=process
----
time->Wed Mar 25 09:33:44 2009
type=SYSCALL msg=audit(1237988024.963:29): arch=80000016 syscall=125 success=no exit=-13 a0=3ffff9ae000 a1=1000 a2=1000007 a3=2000b3775f8 items=0 ppid=1 pid=1857 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="osa-dispatcher" exe="/usr/bin/python" subj=system_u:system_r:osa_dispatcher_t:s0 key=(null)
type=AVC msg=audit(1237988024.963:29): avc:  denied  { execstack } for  pid=1857 comm="osa-dispatcher" scontext=system_u:system_r:osa_dispatcher_t:s0 tcontext=system_u:system_r:osa_dispatcher_t:s0 tclass=process
----
time->Wed Mar 25 09:33:54 2009
type=SYSCALL msg=audit(1237988034.963:30): arch=80000016 syscall=125 success=no exit=-13 a0=3ffff9ae000 a1=1000 a2=1000007 a3=2000c6815f8 items=0 ppid=1 pid=1857 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm="osa-dispatcher" exe="/usr/bin/python" subj=system_u:system_r:osa_dispatcher_t:s0 key=(null)
type=AVC msg=audit(1237988034.963:30): avc:  denied  { execstack } for  pid=1857 comm="osa-dispatcher" scontext=system_u:system_r:osa_dispatcher_t:s0 tcontext=system_u:system_r:osa_dispatcher_t:s0 tclass=process



# /sbin/ausearch -sv no -m AVC -m USER_AVC -m SELINUX_ERR -ts 3/25/2009 9:33:34 | audit2allow 


#============= java_t ==============
allow java_t lib_t:file execmod;

#============= osa_dispatcher_t ==============
allow osa_dispatcher_t self:process execstack;
Comment 1 Clifford Perry 2009-03-26 12:51:25 EDT
The SELinux denial message is different to the tracebacks. The tracebacks attached within the tar file all indicate a network and/or DB connection issue. Was this Satellite's WebUI and other area's functioning correctly with DB communications?  Wondering if the DB was in a failed state or not. Otherwise, we have two possible issues/bugs here within the 5 tracebacks provided, 4 were taskomatic DB connection, the other was cobbler network connection traceback. 

Cliff
Comment 2 Jan Hutař 2009-03-27 03:45:24 EDT
Hello,
this was part of the automated RHTS test so I do not know if WebUI was OK. I'll try to recreate and will let you know:

http://rhts.redhat.com/cgi-bin/rhts/jobs.cgi?id=52308
Comment 3 Jan Hutař 2009-03-27 11:18:25 EDT
Hello,
I have installed 530 again, and email-flood continued. Could you please take a look at: z204.z900.redhat.com root/rhts - I have stopped satellite to get rid of the emails. This RHTS system is reserved for 3 days.
Thank you in advance,
Jan
Comment 4 Brandon Perkins 2009-03-31 15:16:44 EDT
Sorry Jan, we missed it.  Can you set it up again?
Comment 5 Jan Hutař 2009-04-01 09:20:23 EDT
Hello,
not sure if this will help you as current nightly seems to be completely broken on RHEL5 s390x with Enforcing Satellite (I'm not getting any tracebacks right now), but this is what I have done:

# setenforce 0
# ./install.pl --disconnected
Created admin user in the WebUI
# rhn-satellite stop
# setenforce 1
# rhn-satellite stop

You can try yourself on:

z206.z900.redhat.com root/rhts

(will be reserved for next +- 90 hours)



# rhn-satellite restart
Shutting down rhn-satellite...
Stopping RHN Taskomatic...
Stopped RHN Taskomatic.
Stopping cobbler daemon: [  OK  ]
Stopping rhn-search...
Stopped rhn-search.
Stopping MonitoringScout ...  [ OK ]
Stopping Monitoring ...  [ OK ]
Stopping httpd: [  OK  ]
Stopping tomcat5:                                          [  OK  ]
Shutting down osa-dispatcher: [  OK  ]
Shutdown Oracle: Processing Database instance "rhnsat": log file /opt/apps/oracle/web/product/10.2.0/db_1/log/shutdown.log
[  OK  ]
Shutting down Jabber router: [FAILED]
Done.
Starting rhn-satellite...
Starting Jabber services[  OK  ]
Starting Oracle: /opt/apps/oracle/web/product/10.2.0/db_1/bin/lsnrctl: error while loading shared libraries: libclntsh.so.10.1: cannot enable executable stack as shared object requires: Permission denied
Processing Database instance "rhnsat": log file /opt/apps/oracle/web/product/10.2.0/db_1/log/startup.log
[  OK  ]
Starting osa-dispatcher: RHN 29273 2009/04/01 09:16:37 -04:00: ('Connection attempt failed', 12541, 'ORA-12541: TNS:no listener\n')
RHN 29273 2009/04/01 09:16:37 -04:00: ('Error caught:',)
RHN 29273 2009/04/01 09:16:37 -04:00: ('Traceback (most recent call last):\n  File "/usr/share/rhn/osad/jabber_lib.py", line 119, in main\n    self.setup_config(config)\n  File "/usr/share/rhn/osad/osa_dispatcher.py", line 81, in setup_config\n    rhnSQL.initDB()\n  File "/usr/share/rhn/server/rhnSQL/__init__.py", line 98, in initDB\n    __init__DB(backend, host, port, username, password, database)\n  File "/usr/share/rhn/server/rhnSQL/__init__.py", line 52, in __init__DB\n    __DB.connect()\n  File "/usr/share/rhn/server/rhnSQL/driver_cx_Oracle.py", line 333, in connect\n    raise apply(sql_base.SQLConnectError, err_args)\nSQLConnectError: (12541, \'ORA-12541: TNS:no listener\\n\', \'rhnsat\', \'Connection_Connect(): server attach\')\n',)
[  OK  ]
Starting tomcat5:                                          [  OK  ]
Starting httpd: [  OK  ]
Starting Monitoring ...  [ OK ]
Starting MonitoringScout ...  [ OK ]
Starting rhn-search...
Starting cobbler daemon: [  OK  ]
Starting RHN Taskomatic...
Done.
Comment 6 Jan Hutař 2009-04-01 09:39:13 EDT
Err, my fault, I'm getting these tracebacks - so I have stopped the Satellite on that system.
Comment 7 Brandon Perkins 2009-04-02 10:54:18 EDT
Accepting this bug.  We see the connection problems with SELinux in Enforcing, but not in Permissive.
Comment 8 Brandon Perkins 2009-04-02 10:55:18 EDT
Specifically on s390x with the 2009-03-27 ISO.
Comment 9 Jan Pazdziora 2009-04-06 08:59:42 EDT
We hope to have this addressed via bug 491949, in thirdparty repo commit 0325d2d95fa5c2cc40a756da4529243fe2157808.
Comment 10 Jan Pazdziora 2009-04-06 09:01:54 EDT
The package oracle-server-s390x-10.2.0.4-42 is on the Satellite-5.3.0-RHEL5-re20090403.2 ISO.
Comment 11 Jan Pazdziora 2009-04-15 03:17:46 EDT
Moving ON_QA.
Comment 12 John Matthews 2009-06-26 17:24:07 EDT
Installed ISO Satellite-5.3.0-RHEL5-re20090625.0-s390x-embedded-oracle.iso

This is on s390x, I don't see any traceback emails.

Marking VERIFIED
Comment 13 Milan Zazrivec 2009-09-02 07:35:03 EDT
Verified with last stage iso -> RELEASE_PENDING
Comment 14 Brandon Perkins 2009-09-10 15:12:28 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.