Bug 492146 - critical updates icon is no longer a html link to critical updates page for that box
critical updates icon is no longer a html link to critical updates page for t...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
wes hayutin
http://grandprix.rhndev.redhat.com/rh...
: Regression
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-03-25 11:51 EDT by wes hayutin
Modified: 2009-09-10 16:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 492145
Environment:
Last Closed: 2009-09-10 16:34:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-03-25 11:51:48 EDT
+++ This bug was initially created as a clone of Bug #492145 +++

Created an attachment (id=336664)
ss

Description of problem:

Satellite-5.3.0-RHEL5-re20090323.0-i386-embedded-oracle.iso

The icon for a specific system's critical updates used to be a html link to the critical updates page for that box.  You can no longer click on the critical updates icon and be redirected..

you should be.
Comment 1 Justin Sherrill 2009-03-26 16:45:05 EDT
so this was removed based on this bugzilla:
https://bugzilla.redhat.com/show_bug.cgi?id=369651


What do we do?
Comment 2 Justin Sherrill 2009-03-26 16:45:46 EDT
This was the code that removed this:

+++ b/java/code/src/com/redhat/rhn/frontend/taglibs/list/decorators/SystemIconDecorator.java
@@ -49,7 +49,7 @@ public class SystemIconDecorator extends BaseListDecorator {
                 (HttpServletRequest)getCurrentList().getContext().getRequest());

         for (SystemOverview next : systems) {
-            SystemListHelper.setSystemStatusDisplay(context.getLoggedInUser(), next);
+            SystemListHelper.setSystemStatusDisplay(context.getLoggedInUser(), next, false);
         }
     }
 }


b9ef3ebb28596c762bf949f89b0c523a6df22257
Comment 3 Justin Sherrill 2009-03-26 16:50:08 EDT
The icons have been clickable since at least 3.7.
Comment 4 Justin Sherrill 2009-03-27 11:07:38 EDT
made them clickable

commit	2be7e98bf6d9aece2dac9f4c6a21ef118f98af82
tree	9ab5bed31bb62ec9863f9afb073ce216cd83bc3a	tree | snapshot
parent	5efd58f6ac1d3308bdd5151559d6bc5a72e6d81e	commit | diff
Comment 5 wes hayutin 2009-04-06 16:04:05 EDT
verified..
looks great!
Comment 6 Preethi Thomas 2009-08-06 14:20:27 EDT
Release Pending
test1182.test.redhat.com
Comment 7 Brandon Perkins 2009-09-10 16:34:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.