Bug 492149 - Konqueror incorrectly store self window size in maximized mode
Konqueror incorrectly store self window size in maximized mode
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 12:24 EDT by Pavel Alexeev
Modified: 2009-06-01 07:44 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-31 18:04:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 194735 None None None Never

  None (edit)
Description Pavel Alexeev 2009-03-25 12:24:27 EDT
I use Konqueror in XFCE4 DE.
My notebook use 1280x800 screen resolution.

Description of problem:
When I close maximized Konqueror window and then start it again it appeared without menu and even without standard window title, placed on all monitor even cover visible DE pannels.

I'm search, and find what it happened from settings in ~/.kde/share/apps/konqueror/profiles/webbrowsing
Height=200                                                                                                                                                     
Height 800=801
MenuBar=Disabled

If I delete line "Height 800=801" all works as expected - height comes from Height setting. I try both - absolute and percentage values - all work correct on first glance (I does not make metter and calculation of right percent expand).

If say, I write "Height=1000" (note, it is more than used height resolution) - Konqueror start *with* window title, with height of window more than I can see nad under DE panels.

One more things - menu was enabled, but in this situation "MenuBar=Disabled" appeared in config.

Version-Release number of selected component (if applicable):
$ rpm -qa 'kde*'
kdelibs3-3.5.10-3.fc10.i386
kde-l10n-Russian-4.2.1-1.fc10.noarch
kdebase-runtime-4.2.1-2.fc10.i386
kdeutils-printer-applet-4.2.1-3.fc10.i386
kdebase-libs-4.2.1-2.fc10.i386
kdeedu-marble-4.2.1-1.fc10.i386
kdebase-workspace-libs-4.2.1-7.fc10.i386
kdenetwork-libs-4.2.1-1.fc10.i386
kdenetwork-4.2.1-1.fc10.i386
kdebase-workspace-4.2.1-7.fc10.i386
kde-settings-pulseaudio-4.1-6.20090206svn.fc10.1.noarch
kde-i18n-British-3.5.10-2.fc10.noarch
kdelibs-common-4.2.1-4.fc10.i386
kdemultimedia-4.2.1-1.fc10.i386
kde-settings-kdm-4.1-6.20090206svn.fc10.1.noarch
kdebase-runtime-libs-4.2.1-2.fc10.i386
kdeaccessibility-4.2.1-1.fc10.i386
kdeplasma-addons-4.2.1-1.fc10.i386
kde-i18n-Russian-3.5.10-2.fc10.noarch
kde-l10n-British-4.2.1-1.fc10.noarch
kdepimlibs-4.2.1-2.fc10.1.i386
kdegames-libs-4.2.1-1.fc10.i386
kdegraphics-4.2.1-3.fc10.i386
kde-filesystem-4-23.fc10.noarch
kde-settings-4.1-6.20090206svn.fc10.1.noarch
kdelibs-4.2.1-4.fc10.i386
kdemultimedia-libs-4.2.1-1.fc10.i386
kdegames-4.2.1-1.fc10.i386
kdeartwork-4.2.1-1.fc10.i386
kdegraphics-libs-4.2.1-3.fc10.i386
kdebase-4.2.1-2.fc10.i386
kdeutils-4.2.1-3.fc10.i386

How reproducible:
always


Steps to Reproduce:
1. Start Konkueror.
2. Maximize window.
3. Restart.
  
Actual results:
Window appeared as described before - without menu, window title, in size more than may be fit.

Expected results:
Standard window as I close before.
Comment 1 Pavel Alexeev 2009-04-23 08:12:12 EDT
I'm see this problem now widely: Dolphin behaves the same way. And even now I use KDE (but with compiz as window manager), not XFCE!
Comment 2 Steven M. Parrish 2009-05-30 21:48:30 EDT
Thank you for the report.  This is an issue that needs to be addressed by the upstream developers.  Please report this upstream at http://bugs.kde.org  and add the upstream information to this report.
Comment 3 Pavel Alexeev 2009-05-31 05:20:51 EDT
Ok, I fill it to upstream. Set this bug as dependent from it.
Comment 4 Steven M. Parrish 2009-05-31 18:04:53 EDT
Thanks for taking the time to report this upstream.  Will close this for now and monitor the upstream report for a fix.
Comment 5 Pavel Alexeev 2009-06-01 02:51:07 EDT
Why you close BUG? Problem persist. And its depend on extarnal KDE bug, which is not fixed (or closed else) in this time...

I wish leave it in ASSIGNED state and wait resolve of problem, then publish rpm update. What you think?
Comment 6 Rex Dieter 2009-06-01 07:44:32 EDT
From https://bugzilla.redhat.com/page.cgi?id=fields.html#status

Closed->Upstream:
...bugs closed with this resolution are filed in the upstream bugs tracker or reported to the upstream mailing list. This typically includes almost all feature requests and enhancements, and most bugs that we don't consider release showstoppers. (moving a bugs upstream typically increases the chance that someone will have time to look at it.... We only keep bug open on redhat.com to track our immediate short-term TODO items, or issues with our patches/packaging, or because the upstream package in question has poor bug tracking. The main focus of development for most packages is the upstream community, even when Red Hat is a big contributor to the community.)

See also:
https://fedoraproject.org/wiki/PackageMaintainers/WhyUpstream

Hope this helps.

Note You need to log in before you can comment on or make changes to this bug.