Bug 492162 - gnome keyboard shortcuts definition with different layout set is confusing
gnome keyboard shortcuts definition with different layout set is confusing
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: metacity (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 13:11 EDT by michal novacek
Modified: 2014-06-18 05:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-16 11:48:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description michal novacek 2009-03-25 13:11:15 EDT
Description of problem:
Gnome remembers keyboard shortcuts using the keycode and therefore there is
inconsistency between what it shows as shortcut definition and what the
shortcut really is. "Alt+X" is shown but "Alt+Q" actually works when dvorak
layout is set. 

The bottom line on these two different layouts looks as follows:
z X c v b n m , . /    <-- qwerty
; Q j k x b m w v z    <-- dvorak

Version-Release number of selected component (if applicable):

spotted on fedora10

$ rpm -qa | grep gnome | sort
bluez-gnome-1.8-12.fc10.i386
compiz-fusion-gnome-0.7.8-3.fc10.i386
compiz-gnome-0.7.8-7.fc10.i386
fedora-gnome-theme-8.0.0-7.fc10.noarch
gnome-applets-2.24.3.1-1.fc10.i386
gnome-audio-2.22.2-2.fc10.noarch
gnome-backgrounds-2.24.0-2.fc10.noarch
gnome-bluetooth-0.11.0-5.fc10.i386
gnome-bluetooth-libs-0.11.0-5.fc10.i386
gnome-desktop-2.24.3-1.fc10.i386
gnome-desktop-sharp-2.24.0-3.fc10.i386
gnome-device-manager-0.2-3.fc9.i386
gnome-device-manager-libs-0.2-3.fc9.i386
gnome-doc-utils-stylesheets-0.14.0-2.fc10.noarch
gnome-games-2.24.3-2.fc10.i386
gnome-games-help-2.24.3-2.fc10.i386
gnome-icon-theme-2.24.0-1.fc10.noarch
gnome-keyring-2.24.1-1.fc10.i386
gnome-keyring-manager-2.20.0-2.fc9.i386
gnome-keyring-pam-2.24.1-1.fc10.i386
gnome-keyring-sharp-1.0.0-0.2.87622svn.fc10.i386
gnome-mag-0.15.4-1.fc10.i386
gnome-media-2.24.0.1-2.fc10.i386
gnome-menus-2.24.2-1.fc10.i386
gnome-mime-data-2.18.0-3.fc10.noarch
gnome-mount-0.8-1.fc9.i386
gnome-mplayer-common-0.9.4-1.fc10.i386
gnome-packagekit-0.3.14-1.fc10.i386
gnome-panel-2.24.3-1.fc10.i386
gnome-panel-libs-2.24.3-1.fc10.i386
gnome-pilot-2.0.16-2.fc9.i386
gnome-power-manager-2.24.4-1.fc10.i386
gnome-python2-2.22.3-1.fc10.i386
gnome-python2-applet-2.23.0-1.fc10.i386
gnome-python2-bonobo-2.22.3-1.fc10.i386
gnome-python2-canvas-2.22.3-1.fc10.i386
gnome-python2-desktop-2.23.0-1.fc10.i386
gnome-python2-extras-2.19.1-27.fc10.i386
gnome-python2-gconf-2.22.3-1.fc10.i386
gnome-python2-gnome-2.22.3-1.fc10.i386
gnome-python2-gnomekeyring-2.23.0-1.fc10.i386
gnome-python2-gnomeprint-2.23.0-1.fc10.i386
gnome-python2-gnomevfs-2.22.3-1.fc10.i386
gnome-python2-gtkhtml2-2.19.1-27.fc10.i386
gnome-python2-gtksourceview-2.23.0-1.fc10.i386
gnome-python2-libegg-2.19.1-27.fc10.i386
gnome-python2-libwnck-2.23.0-1.fc10.i386
gnome-rdp-0.2.3-2.fc10.i386
gnome-screensaver-2.24.1-2.fc10.i386
gnome-session-2.24.3-1.fc10.i386
gnome-session-xsession-2.24.3-1.fc10.i386
gnome-settings-daemon-2.24.1-7.fc10.i386
gnome-sharp-2.24.0-1.fc10.i386
gnome-speech-0.4.22-1.fc10.i386
gnome-system-monitor-2.24.3-1.fc10.i386
gnome-terminal-2.24.3-1.fc10.i386
gnome-themes-2.24.3-1.fc10.noarch
gnome-user-docs-2.24.2-1.fc10.noarch
gnome-user-share-0.40-3.fc10.i386
gnome-utils-2.24.1-1.fc10.i386
gnome-vfs2-2.24.0-3.fc10.i386

How reproducible:
Always.

Steps to Reproduce:
1. add USA Classic Dvorak layout in
	System->Preferences->Hardware->Keyboard,Layouts,Add
2. change used layout to USA Classic Dvorak 
3. go to System->Preferences->Personal->Keyboard Shortcuts and change "Run
terminal" shortcut to "Alt+X"
  
Actual results:
 "Alt+X" -- nothing happens
 "Alt+Q" -- terminal is run

Expected results:
 terminal is run with "Alt+X" pressed as defined in Keyboards Shortcuts or
 correct key is shown, which would show "Alt+Q" in this case.
Comment 1 michal novacek 2009-03-27 06:15:01 EDT
The same problem goes with gnome-terminal: with Dvorak layout swithed on Ctrl+C doesn't work. I have to press Ctrl+J to get it as on Dvorak "J" is at the place of qwerty "J". 

I suppose it has the same cause as the previously described problem.
Comment 2 Peter Hutterer 2009-04-30 21:53:39 EDT
please run xev and check the output before and after switching. are the key symbols correct?
Comment 3 michal novacek 2009-05-04 04:33:25 EDT
xev catches the correct values, ie: for qwerty 'z' sign it shows ';'

works also with qwerty 'x' --> dvorak 'q' as I mention it in the first example.

I played around a little bit with running terminal using qwerty alt+x and it can be clearly repreduced:
1/ have dvorak layout added
2/ having qwerty sayout switched on, define "Run terminal" shortcut as alt+x
3/ press alt+x to run terminal
4/ switch to dvorak layout and check that pressing 'X' key prints 'Q'
5/ press alt+x (which prints q on dvorak) and see terminal launched

This clearly is wrong as the shortcut is alt+q but shows as alt+x in keyboard shortcuts.
Comment 4 Peter Hutterer 2009-05-04 20:26:34 EDT
Reassigning to metacity, it needs to refresh the key grabs.
Comment 5 Owen Taylor 2009-11-16 11:48:53 EST
I don't see how this has anything to do with Metacity. This looks like the classic GTK+ bug:

 https://bugzilla.gnome.org/show_bug.cgi?id=162726

Which should be fixed in GTK+ 2.16 and 2.18. (F11 and F12.) Closing currentrelease, please reopen if there are still problems.

Note You need to log in before you can comment on or make changes to this bug.