Bug 492193 - Poedit symbol not defined error with libwx_baseu-2.8.so.0
Poedit symbol not defined error with libwx_baseu-2.8.so.0
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: poedit (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Haïkel Guémar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 16:16 EDT by Ville-Pekka Vainio
Modified: 2009-10-09 16:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-10-09 16:39:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville-Pekka Vainio 2009-03-25 16:16:44 EDT
Description of problem:
Poedit doesn't start on Rawhide. The following error is printed:

poedit: relocation error: poedit: symbol _ZN21wxMemoryFSHandlerBase19AddFileWithMimeTypeERK8wxStringPKvjS2_, version WXU_2.8.5 not defined in file libwx_baseu-2.8.so.0 with link time reference

Version-Release number of selected component (if applicable):
poedit-1.4.2-3.fc11.i586
Comment 1 Ville-Pekka Vainio 2009-03-25 16:49:12 EDT
It seems poedit just needs to be rebuilt to fix this. As I'm not a member of the new provenpackager group, I can't do it.
Comment 2 Bill Nottingham 2009-03-26 10:12:23 EDT
I'm firing off a rebuild, but CC'ing a couple of other people for questions:

- Did the wxGTK ABI change without changing the soname (mattdm)?
- Is it possible that something change with symbol mangling in gcc-4.4 that caused this (jakub)?
Comment 3 Bill Nottingham 2009-03-26 10:17:50 EDT
poedit-1.4.2-4.fc11 built in koji.
Comment 4 Bug Zapper 2009-06-09 08:38:01 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Haïkel Guémar 2009-09-18 12:54:18 EDT
Reassigned to myself.
Comment 6 Haïkel Guémar 2009-09-29 04:38:04 EDT
I had no issue either on F-11 or rawhide, unless anyone else has something, I'll close this ticket by the end of the week.
Comment 7 Ville-Pekka Vainio 2009-09-29 04:50:26 EDT
There are no problems with the package anymore, but in Comment #2 Bill Nottingham had some questions for mattdm and jakub. The questions haven't been answered yet, which I guess is why this bug is still open. It's been about six months already, so I guess this can be closed soon if there's no relevant activity...
Comment 8 Haïkel Guémar 2009-10-09 16:39:20 EDT
Than you for your input.
Since it's no more relevant, I'll close this ticket.

Note You need to log in before you can comment on or make changes to this bug.