Bug 492209 - f95 fortran compiler fails with segfault
f95 fortran compiler fails with segfault
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gcc (Show other bugs)
5.3
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Jakub Jelinek
BaseOS QE
:
: 487019 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-25 17:45 EDT by Pam Richardson
Modified: 2009-09-02 07:43 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 07:43:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tar file containing files need to reconstruct the error (1.43 MB, application/x-tar)
2009-03-25 17:47 EDT, Pam Richardson
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNU Compiler Collection 39865 None None None Never

  None (edit)
Description Pam Richardson 2009-03-25 17:45:03 EDT
Description of problem:

The f95 fortran compiler fails with a segfault while attempting to compile file edit.f90.  This may be the same error as bug report 483835. 
 
How reproducible:

I have attached a tar file that contains a readme file and the files needed to reconstruct the error.
Comment 1 Pam Richardson 2009-03-25 17:47:53 EDT
Created attachment 336712 [details]
tar file containing files need to reconstruct the error
Comment 2 Jakub Jelinek 2009-04-23 08:35:20 EDT
Reduced testcase:

module mod
  type t
    real :: v(50)
  end type t
  type (t), target, allocatable, save :: v1(:)
  integer, save :: v2, v3, v4
  character(len=8), save, target, allocatable :: v5(:)
end module mod

subroutine test
  use mod
  integer :: i
  write (*,v5(1:v3)) (v1(i)%v(v2), i=2, v4)
end subroutine test
Comment 3 Jakub Jelinek 2009-05-07 04:40:05 EDT
*** Bug 483845 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Jelinek 2009-05-07 04:40:17 EDT
*** Bug 487019 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Jelinek 2009-05-12 12:09:40 EDT
Patch:
http://gcc.gnu.org/ml/gcc-patches/2009-05/msg00649.html
Comment 13 errata-xmlrpc 2009-09-02 07:43:49 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1376.html

Note You need to log in before you can comment on or make changes to this bug.