Bug 492258 - network-bridge-bonding doesn't support 802.1q vlans
network-bridge-bonding doesn't support 802.1q vlans
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.3
All Linux
urgent Severity medium
: rc
: ---
Assigned To: Jiri Denemark
Virtualization Bugs
: ZStream
Depends On:
Blocks: 502203
  Show dependency treegraph
 
Reported: 2009-03-26 03:51 EDT by Tuomo Soini
Modified: 2010-10-23 04:36 EDT (History)
11 users (show)

See Also:
Fixed In Version: xen-3.0.3-86.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 06:05:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch adding vlan support to network-bridge-bonding (1.37 KB, patch)
2009-03-26 03:51 EDT, Tuomo Soini
no flags Details | Diff
Patch adding vlan support to network-bridge-bonding (1.23 KB, patch)
2009-05-06 14:16 EDT, Jiri Denemark
no flags Details | Diff

  None (edit)
Description Tuomo Soini 2009-03-26 03:51:55 EDT
Created attachment 336760 [details]
Patch adding vlan support to network-bridge-bonding

Description of problem:

when bonding + 802.1q vlans are configured, network-bridge-bonding won't be able to get vlan interfaces up properly because script does ifdown to vlan interfaces.

Version-Release number of selected component (if applicable):

xen-3.0.3-80.el5

How reproducible:

Always

Steps to Reproduce:
1. configure bonding over ethernet interfaces
2. configure 802.1q over bonding
3. make wrapper script to get several network bridges with network-bridge-bonding
  
Actual results:
Only bond0 bridge comes up. bond0.5 and other vlan over bond devices vanish because network-bridge-bonding run ifdown against them which removes vlan device.

Expected results:

pbond0.5 device and bond0.5 bridge.

Additional info:


Wrapper script used:

#!/bin/sh
# /etc/xen/scripts/network-script-local, wrapper for multiple bridges
dir=$(dirname $0)
$dir/network-bridge-bonding $@ netdev=bond0 bridge=bond0
$dir/network-bridge-bonding $@ netdev=bond0.5 bridge=bond0.5
Comment 3 Tuomo Soini 2009-04-27 02:38:24 EDT
There is needinfo requested. Is there any additional info needed?
Comment 4 Bryan Mason 2009-04-27 14:53:51 EDT
The needinfo request was actually intended for some of the Red Hat developers.
Comment 7 Jiri Denemark 2009-05-06 14:16:04 EDT
Created attachment 342694 [details]
Patch adding vlan support to network-bridge-bonding

The original patch looks good. I only expanded the comment above if statement...
Comment 9 Jiri Denemark 2009-05-21 11:40:50 EDT
Fix built into xen-3.0.3-86.el5
Comment 13 Chris Ward 2009-07-03 14:27:56 EDT
~~ Attention - RHEL 5.4 Beta Released! ~~

RHEL 5.4 Beta has been released! There should be a fix present in the Beta release that addresses this particular request. Please test and report back results here, at your earliest convenience. RHEL 5.4 General Availability release is just around the corner!

If you encounter any issues while testing Beta, please describe the issues you have encountered and set the bug into NEED_INFO. If you encounter new issues, please clone this bug to open a new issue and request it be reviewed for inclusion in RHEL 5.4 or a later update, if it is not of urgent severity.

Please do not flip the bug status to VERIFIED. Only post your verification results, and if available, update Verified field with the appropriate value.

Questions can be posted to this bug or your customer or partner representative.
Comment 18 Yewei Shao 2009-07-29 02:59:28 EDT
Verified in xen-3.0.3-91.el5.x86_64
Comment 20 errata-xmlrpc 2009-09-02 06:05:05 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1328.html

Note You need to log in before you can comment on or make changes to this bug.