Bug 492268 - Package jakarta-commons-io is not Required by anything on Satellite 5.3.0, we might want to not ship it
Package jakarta-commons-io is not Required by anything on Satellite 5.3.0, we...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Partha Aji
Red Hat Satellite QA List
:
Depends On:
Blocks: 462714
  Show dependency treegraph
 
Reported: 2009-03-26 05:33 EDT by Tomas Lestach
Modified: 2010-06-30 05:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-06-30 05:31:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Lestach 2009-03-26 05:33:35 EDT
Description of problem:

Package jakarta-commons-io is not Required by anything on Satellite 5.3.0, we might want to not ship it.

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090323.0 on i386
jakarta-commons-io-1.1-0.20051005.2jpp.ep1.1.el5.1.noarch.rpm

How reproducible:

Deterministic.

Steps to Reproduce:
1. Install Satellite 5.3.0.
2. Run rpm -q jakarta-commons-io, check that package jakarta-commons-io is installed.
3. Run rpm -e jakarta-commons-io.
4. Run rpm -q jakarta-commons-io again, check that it's now been removed.
  
Actual results:

Package jakarta-commons-io is installed but it is not required by anything in the Satellite, so it can safely be removed.

Expected results:

Either the package should be Required by some other package, or it should not be on the compose.
Comment 1 Brandon Perkins 2009-03-26 13:26:25 EDT
We definitely do need it.  See:

 Bug 460719 -  RHN Satellite Configuration - Bootstrap throws ISE on RHEL4
 Bug 460208 -  ISE encountered when uploading config file into a config channel

The resolution is that we need a new 1.1 version of jakarta-commons-fileupload.  So, should we:

A) change spacewalk-java to be similar to what we did with jakarta-commons-io in rhn-java-sat change from 5.2 to force a 1.1 version of jakarta-commons-fileupload, which in turn will pull in jakarta-commons-io, or
B) just change comps to require a newer jakarta-commons-fileupload (rebase), which should also pull in jakarta-commons-io automatically.

or is there another solution?
Comment 2 Partha Aji 2009-05-21 04:19:17 EDT
Commons-io i required as a part of commons-fileupload .. Due to bug in the spec file we didn't have the symlink to the /var/lib/tomcat5/rhn/WB-INF/lib directory causing other errors like bz 496254 to happen.
As of http://git.fedorahosted.org/git/?p=spacewalk.git;a=commit;h=092908b71094c1f412d304c3e070a295beed922e this issue should be resolved.
Comment 3 Partha Aji 2009-05-22 11:08:33 EDT
Moving to ON_QA
Comment 4 Steve Salevan 2009-05-26 16:57:00 EDT
[root@530sat ~]# rpm -q jakarta-commons-io
jakarta-commons-io-1.1-0.20051005.2jpp.ep1.1.el5.1

Moving to VERIFIED, tested on 5/21 build.
Comment 5 wes hayutin 2009-08-07 11:54:57 EDT
[root@dhcp77-153 ~]# rpm -e jakarta-commons-io
error: Failed dependencies:
	jakarta-commons-io is needed by (installed) spacewalk-java-0.5.44-37.el5sat.noarch
[root@dhcp77-153 ~]# yum repolist
Loaded plugins: rhnplugin, security
repo id                                   repo name                                              status
redhat-rhn-satellite-5.3-server-i386-5    Red Hat Network Satellite (v5.3 for Server v5 x86)     enabled:   232
rhel-i386-server-5                        Red Hat Enterprise Linux (v. 5 for 32-bit x86)         enabled: 5,887
repolist: 6,119
[root@dhcp77-153 ~]# 


fails qa
Comment 7 Jesus M. Rodriguez 2009-08-07 14:01:05 EDT
jakarta-commons-io *IS* required by spacewalk-java therefore if you try to remove the package it will complain that it spacewalk-java requires it. This was done on purpose.

The original bug stated it was not needed and we shouldn't ship it, but Comment #2 was correct that we DO need it and added an explicit Requires: to the spacewalk-java rpm.

See following comment for the proper test plan.
Comment 8 Jesus M. Rodriguez 2009-08-07 14:01:56 EDT
TEST PLAN
-----------
1. Install Satellite 5.3.0.
2. Run rpm -q jakarta-commons-io, check that package jakarta-commons-io is
installed.
3. Run rpm -e jakarta-commons-io.
4. Should see an error message such as the following one:
error: Failed dependencies:
 jakarta-commons-io is needed by (installed)
spacewalk-java-0.5.44-37.el5sat.noarch
Comment 9 wes hayutin 2009-08-07 14:08:14 EDT
k.. works like it should
Comment 12 Tomas Lestach 2010-06-30 05:31:29 EDT
Closing CURRENTRELEASE. spacewalk-java requires jakarta-commons-io.

Note You need to log in before you can comment on or make changes to this bug.