Bug 492276 - Package perl-Convert-ASCII-Armour is not Required by anything on Satellite 5.3.0, we might want to not ship it
Package perl-Convert-ASCII-Armour is not Required by anything on Satellite 5....
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Shannon Hughes
Steve Salevan
:
Depends On:
Blocks: 463876
  Show dependency treegraph
 
Reported: 2009-03-26 06:34 EDT by Tomas Lestach
Modified: 2009-09-10 14:54 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:54:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Lestach 2009-03-26 06:34:19 EDT
+++ This bug was initially created as a clone of Bug #492121 +++

Description of problem:

Package perl-Convert-ASCII-Armour is not Required by anything on Satellite 5.3.0, we might want to not ship it.

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090323.0 on i386
perl-Convert-ASCII-Armour-1.4-11.el5.noarch.rpm

How reproducible:

Deterministic.

Steps to Reproduce:
1. Install Satellite 5.3.0.
2. Run rpm -q perl-Convert-ASCII-Armour, check that package perl-Convert-ASCII-Armour is installed.
3. Run rpm -e perl-Convert-ASCII-Armour.
4. Run rpm -q perl-Convert-ASCII-Armour again, check that it's now been removed.
  
Actual results:

Package perl-Convert-ASCII-Armour is installed but it is not required by anything in the Satellite, so it can safely be removed.

Expected results:

Either the package should be Required by some other package, or it should not be on the compose.

Additional info:

On Satellite 5.2.0, perl-Convert-ASCII-Armour was needed by perl-Crypt-RSA, but is not required in 5.3.0 any more.
Comment 1 Brandon Perkins 2009-03-26 13:28:41 EDT
Shannon, please look and confirm that this can be removed.
Comment 2 Shannon Hughes 2009-03-27 15:21:28 EDT
confirmed this rpms is not used in the perl code. qa can follow reproducing steps in comment #1 for test plan. 

the corresponding release engineering ticket number to remove from the iso is 38385
Comment 3 Shannon Hughes 2009-04-06 11:09:22 EDT
mass move to onqa
Comment 4 Steve Salevan 2009-04-08 12:26:34 EDT
# rpm -q perl-Convert-ASCII-Armour
package perl-Convert-ASCII-Armour is not installed

Moving to VERIFIED, tested on 530-re20090403.2.
Comment 5 Brandon Perkins 2009-08-07 16:17:23 EDT
Release Pending.  Was in 5.2:

[root@test10-64 ~]# rpm -q perl-Convert-ASCII-Armour
perl-Convert-ASCII-Armour-1.4-11.el4

Now its not on 5.3:

[root@test1182 ~]# rpm -q perl-Convert-ASCII-Armour
package perl-Convert-ASCII-Armour is not installed

Checked both EL4 and EL5.
Comment 6 Brandon Perkins 2009-09-10 14:54:18 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.