This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 492279 - Package perl-Devel-Symdump is not Required by anything on Satellite 5.3.0, we might want to not ship it
Package perl-Devel-Symdump is not Required by anything on Satellite 5.3.0, we...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Michael Mráka
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-03-26 06:48 EDT by Tomas Lestach
Modified: 2009-09-10 16:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:34:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Lestach 2009-03-26 06:48:56 EDT
Description of problem:

Package perl-Devel-Symdump is not Required by anything on Satellite 5.3.0, we might want to not ship it.

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090323.0 on i386
perl-Devel-Symdump-2.03-21.el5.noarch.rpm

How reproducible:

Deterministic.

Steps to Reproduce:
1. Install Satellite 5.3.0.
2. Run rpm -q perl-Devel-Symdump, check that package perl-Devel-Symdump is installed.
3. Run rpm -e perl-Devel-Symdump.
4. Run rpm -q perl-Devel-Symdump again, check that it's now been removed.
  
Actual results:

Package perl-Devel-Symdump is installed but it is not required by anything in the Satellite, so it can safely be removed.

Expected results:

Either the package should be Required by some other package, or it should not be on the compose.
Comment 1 Clifford Perry 2009-03-26 13:43:51 EDT
my %requires = (
    deparse     => ["StatusDeparse",     "B::Deparse",     0.59, ],
    fathom      => ["StatusFathom",      "B::Fathom",      0.05, ],
    symdump     => ["",                  "Devel::Symdump", 2.00, ],
    dumper      => ["StatusDumper",      "Data::Dumper",   0,    ],


above is within: 
vendor_perl/5.8.5/x86_64-linux-thread-multi/Apache2/Status.pm

from mod_perl

We *think* this is in fact needed, and should not be removed, but rpm packaging does not correctly put is as a requires for the package. Mod_perl *should* be fixed. Jan and/or Tomas - someone more familiar with perl - can you confirm that this above code, acts the same as a regular:

           require Devel::Symdump;

? If so, we should maybe clone/open a mod_perl bug for RHEL 4 & 5 for their packaging. 

Thanks,
Cliff.
Comment 2 Tomas Lestach 2009-03-30 05:32:13 EDT
The code is used to require Devel/Symdump.pm, so the package shall NOT be removed. Instead a mod_perl dependency shall be added for this package.
Comment 3 Clifford Perry 2009-03-31 12:19:52 EDT
For RHEL 4 Sat 530 - we ship our own custom rebuilt mod_perl package (if I remember correctly - back ported from RHEL 5's version) - *if* we are able to sanely add this into the spec file and rebuild. Please do so (otherwise we move it off onto sat600-triage, needing upstream - RHEL 5 package to be fixed first). I also suggest to clone a version of this bug for RHEL 5 - so that they can fix their RHEL 5 mod_perl package spec file. 

Cliff
Comment 4 Jan Pazdziora 2009-04-03 04:26:58 EDT
(In reply to comment #1)
> my %requires = (
>     deparse     => ["StatusDeparse",     "B::Deparse",     0.59, ],
>     fathom      => ["StatusFathom",      "B::Fathom",      0.05, ],
>     symdump     => ["",                  "Devel::Symdump", 2.00, ],
>     dumper      => ["StatusDumper",      "Data::Dumper",   0,    ],
> 
> 
> above is within: 
> vendor_perl/5.8.5/x86_64-linux-thread-multi/Apache2/Status.pm
> 
> from mod_perl
> 
> We *think* this is in fact needed, and should not be removed, but rpm packaging
> does not correctly put is as a requires for the package. Mod_perl *should* be
> fixed. Jan and/or Tomas - someone more familiar with perl - can you confirm
> that this above code, acts the same as a regular:
> 
>            require Devel::Symdump;
> 
> ? If so, we should maybe clone/open a mod_perl bug for RHEL 4 & 5 for their
> packaging. 

# grep -r Apache2::Status /etc/httpd/conf*
/etc/httpd/conf.d/perl.conf:#    PerlResponseHandler Apache2::Status

The /perl-status handler is commented out on stock mod_perl installation. So the Apache2::Status is never loaded. And Satellite installation / configuration does not load that module either.

Even if the modules was loaded, there is that "has" method there which is used to determine in runtime if that require passes (it is wrapped in eval), and the only negative effect of not having the module is that the /perl-status will not offer some options that would use that Devel::Symdump.

I'd claim that if RHEL's mod_perl packagers decided not to ship the dependency, and we do not modify the configuration to use Apache2::Status, we should not add the module. There are many more modules in the %requires hash and we do not ship them either.

So: the fact that Apache2::Status code is in mod_perl rpm is *not* a reason to ship perl-Devel-Symdump on Satellite ISO because that code is never used and even if it was used, it is prepared to gracefully handle the situation that the module is not available.

So the original bug report and the original Summary line still holds, unless there is some different reason to think otherwise.
Comment 5 Tomas Lestach 2009-04-21 04:37:15 EDT
rel-eng ticket #39773 to remove perl-Devel-Symdump from satellite composes
Comment 6 Tomas Lestach 2009-04-27 05:41:19 EDT
Package removed since Satellite-5.3.0-RHELx-re20090424.1
Comment 7 Michael Mráka 2009-05-07 09:48:28 EDT
Verified. Satellite-5.3.0-RHEL5-re20090501.1-i386
Comment 8 Jan Pazdziora 2009-05-07 10:02:34 EDT
Putting the original Summary back, to make it clearer what the bugzilla was about.
Comment 9 Miroslav Suchý 2009-08-24 11:38:22 EDT
rpm -q perl-Devel-Symdump
package perl-Devel-Symdump is not installed
[root@xen5 ~]# yum install perl-Devel-Symdump
Loaded plugins: rhnplugin, security
redhat-rhn-satellite-5.3-server-x86_64-5                                                                           | 1.1 kB     00:00
redhat-rhn-satellite-5.3-server-x86_64-5/primary                                                                   | 102 kB     00:00
redhat-rhn-satellite-5.3-server-x86_64-5                                                                                          291/291
rhel-x86_64-server-5                                                                                               | 1.3 kB     00:00
rhel-x86_64-server-5/primary                                                                                       | 2.6 MB     00:06
rhel-x86_64-server-5                                                                                                            7866/7866
rhel-x86_64-server-cluster-5                                                                                       | 1.3 kB     00:00
rhel-x86_64-server-cluster-5/primary                                                                               |  18 kB     00:00
rhel-x86_64-server-cluster-5                                                                                                      124/124
rhel-x86_64-server-cluster-storage-5                                                                               | 1.3 kB     00:00
rhel-x86_64-server-cluster-storage-5/primary                                                                       |  21 kB     00:00
rhel-x86_64-server-cluster-storage-5                                                                                              153/153
rhel-x86_64-server-vt-5                                                                                            | 1.3 kB     00:00
rhel-x86_64-server-vt-5/primary                                                                                    |  43 kB     00:00
rhel-x86_64-server-vt-5                                                                                                           225/225
Setting up Install Process
No package perl-Devel-Symdump available.
Nothing to do


verified in stage on xen5
Comment 10 Brandon Perkins 2009-09-10 16:34:48 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.