Bug 492282 - Package perl-RPM-Specfile is not Required by anything on Satellite 5.3.0, we might want to not ship it
Package perl-RPM-Specfile is not Required by anything on Satellite 5.3.0, we ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Steve Salevan
:
Depends On:
Blocks: 463876
  Show dependency treegraph
 
Reported: 2009-03-26 06:57 EDT by Tomas Lestach
Modified: 2009-09-10 14:54 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:54:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Lestach 2009-03-26 06:57:41 EDT
Description of problem:

Package perl-RPM-Specfile is not Required by anything on Satellite 5.3.0, we might want to not ship it.

Version-Release number of selected component (if applicable):

Satellite-5.3.0-RHEL5-re20090323.0 on i386
perl-RPM-Specfile-1.17-6.el5.noarch.rpm

How reproducible:

Deterministic.

Steps to Reproduce:
1. Install Satellite 5.3.0.
2. Run rpm -q perl-RPM-Specfile, check that package perl-RPM-Specfile is installed.
3. Run rpm -e perl-RPM-Specfile.
4. Run rpm -q perl-RPM-Specfile again, check that it's now been removed.
  
Actual results:

Package perl-RPM-Specfile is installed but it is not required by anything in the Satellite, so it can safely be removed.

Expected results:

Either the package should be Required by some other package, or it should not be on the compose.

Additional info:

On Satellite 5.2.0, perl-RPM-Specfile was needed by perl-Satcon, but is not required in 5.3.0 any more.
Comment 1 Brandon Perkins 2009-03-26 13:52:15 EDT
Justin, please look and confirm that this can be removed.  /usr/bin/satcon-make-rpm.pl has been removed, and appears to be the only thing that used this.
Comment 2 Justin Sherrill 2009-03-27 11:19:00 EDT
Yep, looks like satcon-make-rpm.pl was the only that used it.  We can indeed remove it.
Comment 3 Justin Sherrill 2009-03-27 11:48:45 EDT
Reassigning to dgilmore and opening a releng ticket
Comment 4 Dennis Gilmore 2009-04-02 14:21:23 EDT
removed from 20090401
Comment 5 Steve Salevan 2009-04-08 12:58:48 EDT
# rpm -q perl-RPM-Specfile
package perl-RPM-Specfile is not installed

Moving to VERIFIED, tested on 530-re20090403.2.
Comment 6 John Sefler 2009-08-07 13:29:50 EDT
[root@dhcp77-153 ~]# cat /var/log/rhn/rhn-installation.log | grep Satellite-
(Satellite-5.3.0-RHEL5-re20090724.0)

[root@dhcp77-153 ~]# rpm -q perl-RPM-Specfile
package perl-RPM-Specfile is not installed

moving to RELEASE_PENDING
Comment 7 Brandon Perkins 2009-09-10 14:54:25 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.