Bug 492331 - kernel image from boot.img doesn't boot
kernel image from boot.img doesn't boot
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.8
ia64 Linux
high Severity high
: rc
: ---
Assigned To: Martin Sivák
Alexander Todorov
:
: 492254 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 10:26 EDT by Alexander Todorov
Modified: 2009-05-18 16:16 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-18 16:16:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2009-03-26 10:26:39 EDT
Description of problem:
For ia64 there's a boot.img file under images/ in the tree directory. This contains vmlinuz and initrd.img files and some others. Using them is a no go. System doesn't boot.

Version-Release number of selected component (if applicable):
RHEL4-U8-re20090325.0/kernel-2.6.9-85.EL.ia64.rpm


How reproducible:
Always on ia64

Steps to Reproduce:
1. Loopback mount boot.img and extract vmlinuz and initrd.img files
2. Place the files under /boot/efi/efi/redhat
3. Configure elilo.conf to use the new kernel and boot into that target
  
Actual results:
ELILO boot: anaconda_1
Uncompressing Linux... |

^^^ and it stays like that forever

Expected results:
System boots and install begins

Additional info:
- vmlinuz and initrd.img files from images/pxeboot/ work just fine
- vmlinuz files from pxeboot and boot.img differ. This is by design AFAIK.
- KATE is using boot.img for ia64 which causes all test cases against snap #2 to time out.
Comment 1 Joel Andres Granados 2009-03-26 10:47:42 EDT
FYI. no change has been made to the scripts that generate the images for quite some time.  I doubt that this issue is caused by anaconda changes.
Comment 2 Daniel Mach 2009-03-26 11:23:19 EDT
This issue was probably caused by adding additional modules to the initrd.
Vmlinuz is slightly smaller than the one from pxeboot directory.

Files don't fit to the image:

Filesystem            Size  Used Avail Use% Mounted on
.../boot.img           24M   24M  8.0K 100% /mnt/tmp
Comment 3 Alexander Todorov 2009-03-26 11:41:39 EDT
I think bug #491982 is responsible for adding new modules. Could be wrong though.
Comment 4 Peter Jones 2009-03-26 11:57:26 EDT
This is almost certainly due to running out of space in boot.img, as it is statically sized in rhel4's scripts/mk-images.ia64 .
Comment 5 Joel Andres Granados 2009-03-26 12:42:32 EDT
*** Bug 492254 has been marked as a duplicate of this bug. ***
Comment 6 Martin Sivák 2009-03-26 12:48:31 EDT
Peter was right. I updated the mk-images scripts for ia64 and i386. The images should be OK if created with anaconda-runtime-10.1.1.102.
Comment 7 Alexander Todorov 2009-03-26 12:53:08 EDT
fix goes in anaconda, changing component
Comment 11 errata-xmlrpc 2009-05-18 16:16:19 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0978.html

Note You need to log in before you can comment on or make changes to this bug.