Bug 492347 - "mount -o remount" does not work with crypto devices mounted by mount.crypt
"mount -o remount" does not work with crypto devices mounted by mount.crypt
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pam_mount (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Till Maas
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 11:19 EDT by Bill Nottingham
Modified: 2014-03-16 23:18 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 18:46:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2009-03-26 11:19:12 EDT
Description of problem:

pam_mount now writes the following in /etc/mtab:

/dev/sdb1 /home/notting crypt defaults 0 0

This makes 'mount -o <some option>,remount /home/notting' fail - it tries to operate on /dev/sdb1 (which fails). If you pass the actual device-mapper device, that also fails due to that device not being in fstab or mtab.

It can be made to work by passing "mount -i ...", so that it doesn't actually try to call mount.crypt for the remount.

Version-Release number of selected component (if applicable):

pam_mount-1.20-1.fc11.x86_64
Comment 1 Till Maas 2009-03-26 19:22:15 EDT
I guess the "solution" to the problem is to check for "-o remount" in mount.crypt and only perform the remount of the device-mapper device in this case.

Reported upstream:
https://sourceforge.net/tracker/?func=detail&aid=2715698&group_id=41452&atid=430593
Comment 2 Jan Engelhardt 2009-04-04 17:54:39 EDT
Meh, moving items between trackers changes the URL :-/

https://sourceforge.net/tracker/?func=detail&aid=2715698&group_id=41452&atid=430596
Comment 3 Till Maas 2009-04-13 18:46:12 EDT
This should be fixed in iirc pam_mount-1.22-1.fc11

Btw. what did you need to remount your home directory for?
Comment 4 Bill Nottingham 2009-04-14 12:24:14 EDT
Was playing with noatime/relatime.

Note You need to log in before you can comment on or make changes to this bug.