Bug 492361 - CS 8.0 ESC error message confusing when attempting to format a token with the user that didn't enroll it
CS 8.0 ESC error message confusing when attempting to format a token with the...
Status: CLOSED ERRATA
Product: Dogtag Certificate System
Classification: Community
Component: ESC (Show other bugs)
unspecified
All Windows
urgent Severity low
: ---
: ---
Assigned To: Jack Magne
Chandrasekar Kannan
: TechPreview
Depends On:
Blocks: 443788
  Show dependency treegraph
 
Reported: 2009-03-26 12:10 EDT by Sean Veale
Modified: 2015-01-04 18:37 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Technology Preview
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-22 19:33:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error messages displayed (1.29 MB, application/rtf)
2009-03-26 12:10 EDT, Sean Veale
no flags Details
Patch to fix this issue with the error message. (1.47 KB, patch)
2009-03-28 19:51 EDT, Jack Magne
no flags Details | Diff

  None (edit)
Description Sean Veale 2009-03-26 12:10:47 EDT
Created attachment 336845 [details]
Error messages displayed

Description of problem:
ESC error message confusing when attempting to format a token with the user that didn't enroll it. See attachment. 

Version-Release number of selected component (if applicable):


How reproducible:

Always


Steps to Reproduce:
1. Enroll a token.  
2. Format the token with a valid user name but not the one who enrolled it. See the message.
3. Reset the pin with a user that didn't enroll the token see the clear error message.
  
Actual results:

Confusing / different error messages for the same error condition

Expected results:

Same error message for the same condition.

Additional info:
Comment 1 Jack Magne 2009-03-26 14:06:39 EDT
Agreed this could be better. This may be the case of TPS simply issuing the wrong error code for the Format case.
Comment 2 Jack Magne 2009-03-28 19:51:48 EDT
Created attachment 337136 [details]
Patch to fix this issue with the error message.
Comment 3 Matthew Harmsen 2009-03-28 19:54:15 EDT
attachment (id=337136) +mharmsen
Comment 4 Jack Magne 2009-03-28 20:06:26 EDT
Commit log lost due to server problems. Files affected are

src/processor/RA_Format_Processor.cpp
dogtag/pki-tps/pki-tps.spec
Comment 5 Asha Akkiangady 2009-06-11 17:54:32 EDT
Verified.

Formatting the token with a valid user name but not the one who enrolled it throws error message "Formatting of smart card failed.Error: The Smart Card Server cannot process a smart card which you do not own".

Note You need to log in before you can comment on or make changes to this bug.