This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 492382 - nouveau.modeset=2 works but nouveau.modeset=1 doesn't
nouveau.modeset=2 works but nouveau.modeset=1 doesn't
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
12
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 13:07 EDT by STEVEN WARD
Modified: 2009-12-05 03:53 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-04 13:50:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My latest Xorg.log.txt (20.56 KB, text/plain)
2009-12-04 18:02 EST, STEVEN WARD
no flags Details

  None (edit)
Description STEVEN WARD 2009-03-26 13:07:39 EDT
Description of problem:Wehn I heard of using nouveau.modset in the Fedora forum,I'd thoguht I would try it out.


Version-Release number of selected component (if applicable):


How reproducible:very


Steps to Reproduce:
1.parameters in /boot/grub/menu.list are set to nouveau.modeset=1 just before VGA=
2.Save and re-boot(make sure one can see the graphical boot process)
3.
  
Actual results:Instead of getting me to KDM,the boot process freezes at atd:
I have to do a hard reset before the machine responds.


Expected results:


Additional info:I did a bit of experimenting at the time,and when I setted my nouveau.modeset=2, the kernel boots fine,so this is a bit of a strange one really.
Comment 1 Chris Lumens 2009-03-26 14:47:47 EDT
booty only processes bootloader configuration.  It doesn't have anything to do with those parameters actually working or not.
Comment 2 STEVEN WARD 2009-03-26 16:23:38 EDT
Hi there,
        I'm sorry if I'm confusing people.I didn't mean to select booty.
The problem is real though,if I set the nouveau.modeset=1 in the kernel paramters, it definetly will stop booting at adt,and will not go on to KDM.

If I set the parameter to =2, the boot process will will work normally.

I hope that celars that up.

Regards,
        STEVE555
Comment 3 Ben Skeggs 2009-03-29 18:45:10 EDT
What hardware are you trying to run this on?
Comment 4 Bug Zapper 2009-06-09 08:40:00 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 5 Vedran Miletić 2009-12-04 13:50:14 EST
Reporter, please reopen if you can reproduce this in Fedora 12. Also, please provide more info when reporting (lspci and Xorg log).
Comment 6 STEVEN WARD 2009-12-04 18:02:29 EST
Created attachment 376235 [details]
My latest Xorg.log.txt
Comment 7 STEVEN WARD 2009-12-04 18:13:07 EST
To all,
      I think you can close this bug,as I think I no longer have a problem with K.M.S.I do get the light blue background with the Fedora symbol appearing as the system is booting.(I read somewhere that is how you know K.M.S is working).

I'm currently on the latest Rawhide(Fedora 13),and also compile the git code from D.R.M,Linux-2.6/Nouveau,Mesa,and xf86-video-nouveau.

The current problem I'm having I've posted in the Rawhide section of Fedora Forum.
Here is the output from lspci -vvv:

01:00.0 VGA compatible controller: nVidia Corporation NV40 [GeForce 6800 GT] (rev a1) (prog-if 00 [VGA controller])
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
        Status: Cap+ 66MHz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
        Latency: 32 (1250ns min, 250ns max)
        Interrupt: pin A routed to IRQ 16
        Region 0: Memory at ce000000 (32-bit, non-prefetchable) [size=16M]
        Region 1: Memory at b0000000 (32-bit, prefetchable) [size=256M]
        Region 2: Memory at cd000000 (32-bit, non-prefetchable) [size=16M]
        Expansion ROM at cfee0000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
                Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
                Status: D0 NoSoftRst- PME-Enable- DSel=0 DScale=0 PME-
        Capabilities: [44] AGP version 3.0
                Status: RQ=256 Iso- ArqSz=0 Cal=3 SBA+ ITACoh- GART64- HTrans- 64bit- FW+ AGP3+ Rate=x4,x8
                Command: RQ=32 ArqSz=2 Cal=0 SBA+ AGP+ GART64- 64bit- FW+ Rate=x8
        Kernel driver in use: nouveau
        Kernel modules: nouveau, nvidiafb

Regards,
       STEVE555
Comment 8 STEVEN WARD 2009-12-04 18:37:57 EST
I would also like to add that I'm sorry for not replying earlier,I think at the time I first reported the bug,I found a solution(I can't remember what the solution was back then).And my latest Xorg.0.log is attached at the top of the bug report.
Regards,
       STEVE555
Comment 9 Vedran Miletić 2009-12-05 03:53:18 EST
Well, if it's somehow not fixed in Fedora yet it certainly will be in time for Fedora 13, when rawhide picks up all the relevant stuff that got it fixed for you.

Thanks for reporting back.

Note You need to log in before you can comment on or make changes to this bug.