Bug 492390 - Crash at ../../gdb/gdb.c:47 when GDB was debugging Firefox (trigged by abrt/crash-catcher)
Crash at ../../gdb/gdb.c:47 when GDB was debugging Firefox (trigged by abrt/c...
Status: CLOSED DUPLICATE of bug 491441
Product: Fedora
Classification: Fedora
Component: gdb (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Kratochvil
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-26 13:46 EDT by Michal Nowak
Modified: 2013-03-07 21:05 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-26 15:37:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2009-03-26 13:46:50 EDT
Description of problem:

When I hit bug 491086, the abrt-applet pops up, I open the abrt-gui via the applet and generate report for Firefox crash. Somewhere here the abrt-applet catches GDB's crash. Here's the trace:

Core was generated by `gdb -batch -x /tmp//ccpp-1238088747-26253'.
Program terminated with signal 11, Segmentation fault.
#0  cp_already_canonical (string=<value optimized out>)
    at ../../gdb/cp-support.c:83
83	  if (!ISIDST (string[0]))
#0  cp_already_canonical (string=<value optimized out>)
    at ../../gdb/cp-support.c:83
#1  cp_canonicalize_string (string=<value optimized out>)
    at ../../gdb/cp-support.c:115
#2  0x0000000000546d2d in dwarf2_canonicalize_name (name=0x0, 
    cu=0x7ffff396ea20, obstack=0x7ffff396eaf8) at ../../gdb/dwarf2read.c:8984
#3  0x000000000054701e in read_partial_die (part_die=0x842abe0, 
    abbrev=0x825bdf0, abbrev_len=<value optimized out>, 
    abfd=<value optimized out>, info_ptr=0x7f05e01c24aa "\5O\4\374h.", 
    cu=0x7ffff396ea20) at ../../gdb/dwarf2read.c:6668
#4  0x00000000005473be in load_partial_dies (abfd=<value optimized out>, 
    info_ptr=0x7f05e01c24a5 "\30\360]\35", 
    building_psymtab=<value optimized out>, cu=0x7ffff396ea20)
    at ../../gdb/dwarf2read.c:6474
#5  0x000000000054abe8 in dwarf2_build_psymtabs_hard (objfile=0x2f9fdf0, 
    mainline=<value optimized out>) at ../../gdb/dwarf2read.c:1796
#6  0x00000000004b0d57 in read_psyms (objfile=0x2f9fdf0)
    at ../../gdb/elfread.c:741
#7  0x00000000004e6155 in require_partial_symbols (objfile=0x0)
    at ../../gdb/symtab.c:1193
#8  0x00000000004e7cc7 in find_pc_sect_psymtab (pc=236775183687, section=0x0)
    at ../../gdb/symtab.c:881
#9  0x00000000004e802a in find_pc_sect_symtab (pc=236775183687, section=0x0)
    at ../../gdb/symtab.c:2132
#10 0x00000000004e6030 in blockvector_for_pc_sect (pc=236775183687, 
    section=0x7ffff396ea20, pblock=0x7ffff396ed08, symtab=0x7f05dd51f020)
    at ../../gdb/block.c:115
#11 0x00000000004e6060 in block_for_pc_sect (pc=0, section=0x7ffff396ea20)
    at ../../gdb/block.c:191
#12 0x000000000059d7ad in inline_frame_sniffer (self=<value optimized out>, 
    this_frame=0x1dc4d90, this_cache=<value optimized out>)
    at ../../gdb/inline-frame.c:182
#13 0x000000000059be07 in frame_unwind_find_by_frame (this_frame=0x1dc4d90, 
    this_cache=0x1dc4d98) at ../../gdb/frame-unwind.c:102
#14 0x0000000000598ac1 in get_frame_type (frame=0x1dc4d90)
    at ../../gdb/frame.c:1851
#15 0x0000000000598d48 in get_frame_address_in_block (this_frame=0x1dc4d90)
    at ../../gdb/frame.c:1724
#16 0x000000000050b2c6 in backtrace_command_1 (from_tty=<value optimized out>, 
    show_locals=<value optimized out>, count_exp=<value optimized out>)
    at ../../gdb/stack.c:1278
#17 backtrace_command_stub (from_tty=<value optimized out>, 
    show_locals=<value optimized out>, count_exp=<value optimized out>)
    at ../../gdb/stack.c:1330
#18 0x000000000050e544 in catch_errors (func=<value optimized out>, 
    func_args=<value optimized out>, errstring=<value optimized out>, 
    mask=<value optimized out>) at ../../gdb/exceptions.c:516
#19 0x0000000000509e43 in backtrace_command (arg=<value optimized out>, 
    from_tty=<value optimized out>) at ../../gdb/stack.c:1388
#20 0x000000000044c790 in execute_command (p=0x1e4b6e2 "", from_tty=0)
    at ../../gdb/top.c:450
#21 0x000000000044c8b6 in command_loop () at ../../gdb/top.c:529
#22 0x000000000044ca61 in read_command_file (stream=0x1e722f0)
    at ../../gdb/top.c:332
#23 0x000000000050e738 in catch_exception (uiout=<value optimized out>, 
    func=<value optimized out>, func_args=<value optimized out>, 
    mask=<value optimized out>) at ../../gdb/exceptions.c:470
#24 0x000000000048eb90 in script_from_file (stream=0x1e722f0, 
    file=0x1e679a0 "/tmp/ccpp-1238088747-26253")
    at ../../gdb/cli/cli-script.c:1525
#25 0x000000000049327f in source_script (
    file=0x1e679a0 "/tmp/ccpp-1238088747-26253", 
    from_tty=<value optimized out>) at ../../gdb/cli/cli-cmds.c:511
#26 0x000000000050e4af in catch_command_errors (command=<value optimized out>, 
    arg=<value optimized out>, from_tty=<value optimized out>, 
    mask=<value optimized out>) at ../../gdb/exceptions.c:531
#27 0x0000000000445029 in captured_main (data=<value optimized out>)
    at ../../gdb/main.c:933
#28 0x000000000050e544 in catch_errors (func=<value optimized out>, 
    func_args=<value optimized out>, errstring=<value optimized out>, 
    mask=<value optimized out>) at ../../gdb/exceptions.c:516
#29 0x0000000000444874 in gdb_main (args=0x7ffff396ea20)
    at ../../gdb/main.c:999
#30 0x0000000000444849 in main (argc=<value optimized out>, 
    argv=0x7ffff396ea20) at ../../gdb/gdb.c:47

I've seen this crash several time before.

Version-Release number of selected component (if applicable):

gdb-6.8.50.20090302-8.fc11.x86_64

How reproducible:

always
Comment 1 Jan Kratochvil 2009-03-26 15:37:19 EDT
Already fixed in Rawhide, just the Rawhide-freeze blocks its distribution:
http://koji.fedoraproject.org/koji/buildinfo?buildID=94187
* Sun Mar 15 2009 Jan Kratochvil <jan.kratochvil@redhat.com> -
6.8.50.20090302-10
 - Archer update to the snapshot: 935f217d3367a642374bc56c6b146d376fc3edab
 - Archer backport: 281278326412f9d6a3fabb8adc1d419fd7ddc7d7
   - Fix [expr] crash reading invalid DWARF C++ symbol "" (BZ 490319).

*** This bug has been marked as a duplicate of bug 491441 ***

Note You need to log in before you can comment on or make changes to this bug.