Bug 492476 - SDC Page, critical and non-critical errata dont add up to total errata
SDC Page, critical and non-critical errata dont add up to total errata
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Justin Sherrill
wes hayutin
https://grandprix.rhndev.redhat.com/r...
:
Depends On:
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-03-26 17:54 EDT by wes hayutin
Modified: 2009-09-10 16:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:34:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ss (475.38 KB, image/png)
2009-03-26 17:54 EDT, wes hayutin
no flags Details
ss (494.18 KB, image/png)
2009-03-26 17:54 EDT, wes hayutin
no flags Details

  None (edit)
Description wes hayutin 2009-03-26 17:54:01 EDT
Created attachment 336915 [details]
ss

Description of problem:
Satellite-5.3.0-RHEL5-re20090323.0-i386-embedded-oracle.iso
SDC Page, critical and non-critical errata dont add up to total errata

On the sdc page for rhel 4 box... I see

Critical:  109    Non-Critical:  272  as the count for errata

272+109=381

The total errata listed when you navigate to: 
rhn/systems/details/ErrataList.do?sid=1000010200

total errata= 421


To the best of my knowledge there are three types of errata
    * Security   = critical
    * Bug Fix    = non-critical
    * Enhancement= non-critical

If thats not true, then the behavior may be correct.

screenshots included


The critical + non-critical errata in this case SHOULD equal 421.
Comment 1 wes hayutin 2009-03-26 17:54:28 EDT
Created attachment 336916 [details]
ss
Comment 2 wes hayutin 2009-03-26 18:18:25 EDT
heh.. looks like a regression
https://bugzilla.redhat.com/show_bug.cgi?id=368841
Comment 3 Justin Sherrill 2009-03-27 11:08:29 EDT
commit	349547571ee6818af4208da2898ed19fa35e3543
tree	d8b5eea9305a1a2804b36b1c2c678caa4c8f1c1a	tree | snapshot
parent	2be7e98bf6d9aece2dac9f4c6a21ef118f98af82	commit | diff


the queries were evidently using the old old rhnNeededPackageCache (not even NeededErrataCache).  rhnNeededPackageCache isn't reliable for errata information.
Comment 4 wes hayutin 2009-04-09 12:57:55 EDT
verified..
Comment 5 Tomas Lestach 2009-08-26 03:20:46 EDT
Verified on four different systems that the sum of critical and non-critical errata corresponds to the total amount of errata.

Stage validated -> RELEASE_PENDING
Comment 6 Brandon Perkins 2009-09-10 16:34:50 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.