Bug 492531 - Add Requires: lksctp-tools = %{version}-%{release} to lksctp-tools-devel
Add Requires: lksctp-tools = %{version}-%{release} to lksctp-tools-devel
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lksctp-tools (Show other bugs)
5.4
All Linux
medium Severity medium
: rc
: ---
Assigned To: Zdenek Prikryl
BaseOS QE
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-27 05:26 EDT by Michal Nowak
Modified: 2013-04-15 05:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 03:45:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Nowak 2009-03-27 05:26:31 EDT
Description of problem:

Subpackage lksctp-tools-devel on i386 ppc s390 consumes library(s) libsctp.so.1 libwithsctp.so.1 from subpackage lksctp-tools but does not have explicit package version requirement lksctp-tools = 1.0.6-2.el5<br/>Please add Requires: lksctp-tools = %{version}-%{release} to lksctp-tools-devel in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages. 

Subpackage lksctp-tools-devel on x86_64 ia64 ppc64 s390x consumes library(s) libsctp.so.1()(64bit) libwithsctp.so.1()(64bit) from subpackage lksctp-tools but does not have explicit package version requirement lksctp-tools = 1.0.6-2.el5<br/>Please add Requires: lksctp-tools = %{version}-%{release} to lksctp-tools-devel in the specfile to avoid the need to test interoperability between the various combinations of old and new subpackages. 

Version-Release number of selected component (if applicable):

lksctp-tools-1.0.6-2.el5

How reproducible:

always
  
Actual results:

No explicit dependency in -devel sub-package on main pkg.

Expected results:

Explicit dependency in -devel sub-package on main pkg.

Additional info:

This is really easy stuff and we have a record (bug 454248) of having problems with this.
Comment 6 errata-xmlrpc 2009-04-08 03:45:57 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0412.html

Note You need to log in before you can comment on or make changes to this bug.