Bug 492549 - Edit partition property
Edit partition property
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:4af7323fcb5472ba4...
:
: 496923 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-27 08:16 EDT by Nicolas Chauvet (kwizart)
Modified: 2009-04-21 13:06 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-13 13:53:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (56.28 KB, text/plain)
2009-03-27 08:16 EDT, Nicolas Chauvet (kwizart)
no flags Details

  None (edit)
Description Nicolas Chauvet (kwizart) 2009-03-27 08:16:36 EDT
The following was filed automatically by anaconda:
anaconda None exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/formats/fs.py", line 743, in minSize
    raise FSError("failed to get minimum fs size")
  File "/usr/lib/anaconda/storage/devices.py", line 548, in minSize
    if self.format.minSize:
  File "/usr/lib/anaconda/iw/partition_ui_helpers_gui.py", line 363, in createPreExistFSOptionSection
    reqlower = origrequest.minSize
  File "/usr/lib/anaconda/iw/partition_dialog_gui.py", line 383, in __init__
    (row, self.fsoptionsDict) = createPreExistFSOptionSection(self.origrequest, maintable, row, self.mountCombo, self.storage, luksdev=luksdev)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1118, in editPartition
    restrictfs = restrictfs)
  File "/usr/lib/anaconda/iw/partition_gui.py", line 1082, in editCB
    self.editPartition(device)
FSError: failed to get minimum fs size
Comment 1 Nicolas Chauvet (kwizart) 2009-03-27 08:16:44 EDT
Created attachment 336997 [details]
Attached traceback automatically from anaconda.
Comment 2 Chris Lumens 2009-04-13 13:31:48 EDT
Okay, I see what's going on here now.  We're examining the output of resize2fs to see what the minimum allowed size is, but the output is not in English and we're comparing the results to an English string.  So of course it never matches.
Comment 3 Chris Lumens 2009-04-21 13:06:07 EDT
*** Bug 496923 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.