Bug 492588 - child shared channels of private parent channels are not available for activation key child channels.
child shared channels of private parent channels are not available for activa...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Other (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Ortel
Preethi Thomas
: Reopened
Depends On: 498075
Blocks: 456998
  Show dependency treegraph
 
Reported: 2009-03-27 11:20 EDT by Preethi Thomas
Modified: 2009-09-10 15:48 EDT (History)
5 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:48:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Preethi Thomas 2009-03-27 11:20:24 EDT
Description of problem:

child shared channels of private parent channels are not available for activation key child channels.
Version-Release number of selected component (if applicable):
Satellite-5.3.0-RHEL5-re20090323.0-i386-embedded-oracle.iso

How reproducible:


Steps to Reproduce:
1.create 2 orgs org1 & org2 with trust.
2.create a shared child channel as the child of Rhel channel (rhel4 or rhel5) in org1
3.in org2 create an activation key.
4.naviagate to the child channel tab for the activation key.
5. browse to see the shares child channel from above.
  
Actual results:

the shared channels that are child channel of private parent channels are not available for selection in child channel list.

Expected results:

should be able to child shared channels of redhat channels from activation keys.
Additional info:
Comment 1 wes hayutin 2009-04-03 10:37:24 EDT

*** This bug has been marked as a duplicate of bug 480674 ***
Comment 2 Preethi Thomas 2009-04-22 12:47:18 EDT
I am reopening this one, as this is still an issue with
Satellite-5.3.0-RHEL5-re20090420.0-i386-embedded-oracle.iso
Comment 3 Shannon Hughes 2009-04-30 10:48:24 EDT
looks like the java stack was fixed but perl stack was not
Comment 4 Shannon Hughes 2009-04-30 17:21:50 EDT
modified perl query to use rhnSharedChannelView vs rhnChannel. 

keep in mind you will need to make sure you choose a base channel that has the shared channel in it.
Comment 5 Shannon Hughes 2009-05-04 16:45:57 EDT
i need to look at this again, moving back to assigned.
Comment 6 Brad Buckingham 2009-05-07 10:10:19 EDT
when verifying this bugzilla, we need to ensure that the following scenario is still functioning properly:

1. clone an x86_64 base channel
2. clone an i386 channel as a child of the channel in 1
3. create an activation key that uses the channel in 1 as the base channel
4. update the activation key to include the child channel included in 2

with the initial fix, for step 4 the child channel wasn't listed as a channel for selection; however, it should be and it should be selectable.
Comment 7 Shannon Hughes 2009-05-07 15:41:18 EDT
query needed an left outer join between rhnChannel and rhnSharedChannelView
Comment 8 Shannon Hughes 2009-05-20 12:02:40 EDT
mass move to onqa
Comment 9 Preethi Thomas 2009-06-01 14:07:02 EDT
fails_qa
Satellite-5.3.0-RHEL5-re20090529.0-i386-embedded-oracle.iso


Steps to Reproduce:
1.create 2 orgs org1 & org2 with trust.
2.create a shared child channel as the child of Rhel channel (rhel4 or rhel5)
in org1
3.in org2 create an activation key.
4.naviagate to the child channel tab for the activation key.
5. browse to see the shares child channel from above.
Comment 11 Preethi Thomas 2009-06-08 13:31:23 EDT
rlx-3-24 satellite.
I have a channel named child-channel-rhel-pub as a public channel and is a child of the rhel-4 channel in pt-org1.

Now login as pt-org2
if you navigate to channel-> My shared channel
the you expand the no access to parent channel entry you can see that child-channel-rhel-pub is a shred channel from org pt-org1.
Now navigate to systems->activation key.
click on key-492588 that is created with the redhat rhel4 channel as the base channel.

Navigate to the child channel tab.

see that only the rhel4 tools channel is available for selection.

child-channel-rhel-pub is not available.
Comment 12 Jeff Ortel 2009-06-09 16:31:12 EDT
The problem is in the rhnSharedChannelTreeView.  This view only shows the tree of shared channels.  In this case, the parent channel is a non-shared Red Hat channel so It was omitted from the tree.   The fix is to change the join in the 2nd part of the union so that the parent channel information comes from the rhnChannel table instead of joining rhnSharedChannelView to itself.

f91358408ef1528f8298544188eabf3bff649509
Comment 13 Milan Zázrivec 2009-06-10 12:21:02 EDT
(In reply to comment #12)
> The problem is in the rhnSharedChannelTreeView.  This view only shows the tree
> of shared channels.  In this case, the parent channel is a non-shared Red Hat
> channel so It was omitted from the tree.   The fix is to change the join in the
> 2nd part of the union so that the parent channel information comes from the
> rhnChannel table instead of joining rhnSharedChannelView to itself.
> 
> f91358408ef1528f8298544188eabf3bff649509  

Schema upgrade script 190-rhnSharedChannelTreeView.sql from the commit above
should have gone into spacewalk-schema-0.5-to-spacewalk-schema-0.6
directory, not spacewalk-0.4-spacewalk-0.5.
Comment 14 Jeff Ortel 2009-06-10 14:29:32 EDT
(In reply to comment #13)
> (In reply to comment #12)
> > The problem is in the rhnSharedChannelTreeView.  This view only shows the tree
> > of shared channels.  In this case, the parent channel is a non-shared Red Hat
> > channel so It was omitted from the tree.   The fix is to change the join in the
> > 2nd part of the union so that the parent channel information comes from the
> > rhnChannel table instead of joining rhnSharedChannelView to itself.
> > 
> > f91358408ef1528f8298544188eabf3bff649509  
> 
> Schema upgrade script 190-rhnSharedChannelTreeView.sql from the commit above
> should have gone into spacewalk-schema-0.5-to-spacewalk-schema-0.6
> directory, not spacewalk-0.4-spacewalk-0.5.  

Moved upgrade script to spacewalk-schema-0.5-to-spacewalk-schema-0.6/.
15ef0361b300e8b8e30aa54ce03caa67cfe5271d

Milan, good catch!  Thanks!
Comment 15 wes hayutin 2009-06-17 09:40:52 EDT
verified 6/12.1
Comment 16 Miroslav Suchý 2009-08-05 05:00:28 EDT
verified in stage.
Comment 17 Brandon Perkins 2009-09-10 15:48:45 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.