Bug 492607 - Build Error : "error: Installed (but unpackaged) file(s) found: " when nautilus-cd-burner is installed [NEEDINFO]
Build Error : "error: Installed (but unpackaged) file(s) found: " when nautil...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gnome-python2-desktop (Show other bugs)
5.3
s390x Linux
low Severity low
: rc
: ---
Assigned To: Matthew Barnes
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-27 13:12 EDT by lihuang
Modified: 2014-06-02 09:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:09:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
pm-rhel: needinfo? (lihuang)


Attachments (Terms of Use)

  None (edit)
Description lihuang 2009-03-27 13:12:37 EDT
Description of problem:
on s390x arch, failed to build gnome-python2-desktop-2.16.0-3.el5 if package nautilus-cd-burner is installed .



Build log:
begin at 02/12/2009 10:32:22 on s390x-5s-2-v1.z900.redhat.com doRpmCommand: s390x rpmbuild --rebuild --define "dist .el5" --target=s390x --rcfile /tmp/tps_rpmrc_s11620:/usr/lib/rpm/rpmrc:/usr/lib/rpm/redhat/rpmrc /mnt/redhat/brewroot/packages/gnome-python2-desktop/2.16.0/3.el5/src/gnome-python2-desktop-2.16.0-3.el5.src.rpm doRpmCommand-result (256): FAILED to rebuild /mnt/redhat/brewroot/packages/gnome-python2-desktop/2.16.0/3.el5/src/gnome-python2-desktop-2.16.0-3.el5.src.rpm -- return code 256 REBUILD: FAIL for gnome-python2-desktop-2.16.0-3.el5.src.rpm BUILDLOG: gnome-python2-desktop-2.16.0-3.el5.src.rpm-s390x-rebuild.log contains full details. Reports from make and rpmbuild, with line numbers: 1289-Requires: gnome-keyring gnome-python2-desktop = 2.16.0-3.el5 libc.so.6()(64bit) libc.so.6(GLIBC_2.2)(64bit) libc.so.6(GLIBC_2.4)(64bit) libglib-2.0.so.0()(64bit) libgnome-keyring.so.0()(64bit) libgobject-2.0.so.0()(64bit) python(abi) = 2.4 rtld(GNU_HASH) 1290-Processing files: gnome-python2-desktop-debuginfo-2.16.0-3.el5 1291-Provides: _gnomedesktop.so.debug()(64bit) _print.so.debug()(64bit) gnomeapplet.so.debug()(64bit) gnomekeyring.so.debug()(64bit) gtksourceview.so.debug()(64bit) gtop.so.debug()(64bit) metacity.so.debug()(64bit) nautilusburn.so.debug()(64bit) plparser.so.debug()(64bit) rsvg.so.debug()(64bit) ui.so.debug()(64bit) wnck.so.debug()(64bit) 1292-Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1 1293-Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/gnome-python2-desktop-2.16.0-3.el5-root 1294:error: Installed (but unpackaged) file(s) found: 1295- /usr/lib64/python2.4/site-packages/gtk-2.0/nautilusburn.so 1296- 1297- 1298-RPM build errors: 1299- user mockbuild does not exist - using root Last 20 lines of Build Log: Requires: gnome-keyring gnome-python2-desktop = 2.16.0-3.el5 libc.so.6()(64bit) libc.so.6(GLIBC_2.2)(64bit) libc.so.6(GLIBC_2.4)(64bit) libglib-2.0.so.0()(64bit) libgnome-keyring.so.0()(64bit) libgobject-2.0.so.0()(64bit) python(abi) = 2.4 rtld(GNU_HASH) Processing files: gnome-python2-desktop-debuginfo-2.16.0-3.el5 Provides: _gnomedesktop.so.debug()(64bit) _print.so.debug()(64bit) gnomeapplet.so.debug()(64bit) gnomekeyring.so.debug()(64bit) gtksourceview.so.debug()(64bit) gtop.so.debug()(64bit) metacity.so.debug()(64bit) nautilusburn.so.debug()(64bit) plparser.so.debug()(64bit) rsvg.so.debug()(64bit) ui.so.debug()(64bit) wnck.so.debug()(64bit) Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1 Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/gnome-python2-desktop-2.16.0-3.el5-root error: Installed (but unpackaged) file(s) found: /usr/lib64/python2.4/site-packages/gtk-2.0/nautilusburn.so RPM build errors: user mockbuild does not exist - using root group mockbuild does not exist - using root user mockbuild does not exist - using root group mockbuild does not exist - using root user mockbuild does not exist - using root group mockbuild does not exist - using root user mockbuild does not exist - using root group mockbuild does not exist - using root Installed (but unpackaged) file(s) found: /usr/lib64/python2.4/site-packages/gtk-2.0/nautilusburn.so =============== 


Version-Release number of selected component (if applicable):
gnome-python2-desktop-2.16.0-2.el5.s390x

How reproducible:
Everytime.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Matthew Barnes 2009-03-27 15:02:07 EDT
I guess the fact that nautilus-cd-burner is present on s390(x) suggests that perhaps gnome-python2-nautilus-cd-burner can now be built on those arches.

Slots are full for 5.4 so proposing this for 5.5, but probably not worth fixing until there's more important gnome-python2-desktop bugs.
Comment 2 RHEL Product and Program Management 2009-11-06 14:02:57 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 3 RHEL Product and Program Management 2014-03-07 08:41:20 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 4 RHEL Product and Program Management 2014-06-02 09:09:26 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.