Bug 492619 - Exception type cx_Oracle.DatabaseError, Exception while handling function handler
Exception type cx_Oracle.DatabaseError, Exception while handling function han...
Status: CLOSED DUPLICATE of bug 491673
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
wes hayutin
na
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-27 14:27 EDT by wes hayutin
Modified: 2009-04-27 12:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-27 09:22:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spacewalk-debug (5.20 MB, application/octet-stream)
2009-03-27 14:32 EDT, wes hayutin
no flags Details

  None (edit)
Description wes hayutin 2009-03-27 14:27:51 EDT
Description of problem:

Exception type cx_Oracle.DatabaseError, Exception while handling function handler
3/23 build
embedded db on x86

not sure how I got this, but I've seen this traceback several times in the last two weeks.  Opening so dev can take a look.




Exception reported from riverraid.rhndev.redhat.com
Time: Fri Mar 27 12:09:13 2009
Exception type cx_Oracle.DatabaseError
Exception while handling function handler
Request object information:
URI: /XMLRPC
Remote Host: fjs-0-12.rhndev.redhat.com
Server Name: riverraid.rhndev.redhat.com:0
Headers passed in:
        Accept-Encoding: identity
        Content-Length: 881
        Host: riverraid.rhndev.redhat.com
        content-type: text/xml
        user-agent: rhn.rpclib.py/$Revision: 92982 $
        x-client-version: 1
        x-info: RPC Processor (C) Red Hat, Inc (version 118741)
        x-rhn-client-capability: packages.verifyAll(1)=1,packages.verify(1)=1,packages.extended_profile(1)=1,configfiles.base64_enc(1)=1,reboot.reboot(1)=1,configfiles.deploy(1)=1,caneatCheese(1)=1,packages.rollBack(1)=1,configfiles.mtime_upload(1)=1,configfiles.diff(1)=1,script.run(1)=1,configfiles.upload(1)=1,packages.runTransaction(1)=1
        x-rhn-transport-capability: follow-redirects=2
        x-transport-info: Extended Capabilities Transport (C) Red Hat, Inc (version 92982)
        x-up2date-version: 4.7.1-17.el4
Extra information about this error:
Unhandled exception type

Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/server/apacheServer.py", line 58, in __call__
    ret = f(req)
  File "/usr/share/rhn/server/apacheHandler.py", line 201, in handler
    rhnSQL.rollback()
  File "/usr/share/rhn/server/rhnSQL/__init__.py", line 179, in rollback
    return db.rollback(name)
  File "/usr/share/rhn/server/rhnSQL/driver_cx_Oracle.py", line 433, in rollback
    return self.dbh.rollback()
DatabaseError: ORA-03114: not connected to ORACLE


Local variables by frame
Frame rollback in /usr/share/rhn/server/rhnSQL/driver_cx_Oracle.py at line 433
                        self = <type 'instance'> <server.rhnSQL.driver_cx_Oracle.Database instance at 0xb7ba438c>
                        name = <type 'NoneType'> None

Frame rollback in /usr/share/rhn/server/rhnSQL/__init__.py at line 179
                          db = <type 'instance'> <server.rhnSQL.driver_cx_Oracle.Database instance at 0xb7ba438c>
                        name = <type 'NoneType'> None

Frame handler in /usr/share/rhn/server/apacheHandler.py at line 201
                           h = <type 'instance'> <__builtin__.OracleCursor on <cx_Oracle.Connection to rhnsat@rhnsat>>
                        self = <type 'instance'> <server.apacheHandler.apacheHandler instance at 0xb7c7e74c>
                         req = <type 'mp_request'> <mp_request object at 0xb35a3c5c>
                         ret = <type 'int'> 0
             templateStrings = <type 'dict'> {'email_account_info': '\nAccount Information:\n  Your RHN login:         <login />\n  Your RHN email address: <email-address />', 'email_footer': '--the Red Hat Network Team', 'hostname': 'riverraid.rhndev.redhat.com'}
                         row = <type 'NoneType'> None

Frame __call__ in /usr/share/rhn/server/apacheServer.py at line 63
                        self = <type 'instance'> <server.apacheServer.HandlerWrap instance at 0xb7d21e0c>
                         req = <type 'mp_request'> <mp_request object at 0xb35a3c5c>
                           f = <type 'instancemethod'> <bound method apacheHandler.handler of <server.apacheHandler.apacheHandler instance at 0xb7c7e74c>>

Frame HandlerDispatch in /usr/lib/python2.4/site-packages/mod_python/apache.py at line 299
                         req = <type 'mp_request'> <mp_request object at 0xb35a3c5c>
                      config = <type 'mp_table'> {'PythonInterpreter': 'rhn.server', 'PythonPath': 'sys.path+['/usr/share/rhn']'}
                        self = <type 'instance'> <mod_python.apache.CallBack instance at 0xb7f3176c>
                      object = <type 'instance'> <server.apacheServer.HandlerWrap instance at 0xb7d21e0c>
                           l = <type 'list'> ['server.apacheServer', 'Handler']
                      module = <type 'module'> <module 'server.apacheServer' from '/usr/share/rhn/server/apacheServer.pyc'>
                       hlist = <type 'mp_hlist'> {'handler:'server.apacheServer::Handler','directory':'/XMLRPC/','silent':0}
                  object_str = <type 'str'> Handler
                       debug = <type 'int'> 0
                 module_name = <type 'str'> server.apacheServer
                  pathstring = <type 'str'> sys.path+['/usr/share/rhn']
                      result = <type 'int'> 500


Environment for PID=19595 on exception:
LANG = C
NLS_LANG = english.AL32UTF8
ORACLE_HOME = /opt/oracle
PATH = /sbin:/usr/sbin:/bin:/usr/bin
PERL_BADFREE = 0
PWD = /
SHLVL = 2
TERM = dumb
_ = /usr/sbin/httpd
Comment 1 wes hayutin 2009-03-27 14:32:37 EDT
Created attachment 337050 [details]
spacewalk-debug
Comment 2 Brandon Perkins 2009-03-31 12:08:44 EDT
Jan, can you take a glance at this and see if anything pops-out other than the:

DatabaseError: ORA-03114: not connected to ORACLE

There doesn't appear to be enough info here to go on, but if you find something, please let us know.
Comment 3 Jan Pazdziora 2009-04-06 06:03:42 EDT
Could we get alert.log from that Satellite server to see why the connection was closed?
Comment 4 Brandon Perkins 2009-04-07 13:21:38 EDT
Needinfo for Wes for  -------  Comment #3 From  Jan
Comment 5 Jan Pazdziora 2009-04-27 09:22:02 EDT
Let's use bug 491673 for Oracle server core dumping issues.

*** This bug has been marked as a duplicate of bug 491673 ***

Note You need to log in before you can comment on or make changes to this bug.