Bug 492643 - ltsp-vmclient: "No valid PXE rom found for network device"
ltsp-vmclient: "No valid PXE rom found for network device"
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ltsp (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Warren Togami
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-27 16:02 EDT by Dan Young
Modified: 2009-03-30 15:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-30 15:57:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
trival patch to fix PXE rom path (447 bytes, patch)
2009-03-27 16:03 EDT, Dan Young
no flags Details | Diff

  None (edit)
Description Dan Young 2009-03-27 16:02:32 EDT
Description of problem:
The path to the PXE bootrom used by ltsp-vmclient has changed because of the QEMU/KVM unification. /etc/ltsp/vmclient needs to be updated to match the new location. Patch is attached.

Version-Release number of selected component (if applicable):
5.1.58-2

How reproducible:
Always.

Steps to Reproduce:
1. su -
2. ltsp-vmclient

  
Actual results:
+ qemu-kvm -soundhw all -hda /dev/null -boot n -m 256 -net tap,script=/usr/sbin/ltsp-qemu-bridge-ifup
Warning: vlan 0 with no nics
No valid PXE rom found for network device


Expected results:
KVM starts.

Additional info:
I think I still have commit on the BZR repo, so I can probably fumble through fixing this myself.
Comment 1 Dan Young 2009-03-27 16:03:36 EDT
Created attachment 337058 [details]
trival patch to fix PXE rom path
Comment 2 Dan Young 2009-03-30 15:57:26 EDT
Saw that this is fixed in 5.1.67-1.

Note You need to log in before you can comment on or make changes to this bug.