Bug 492645 - focus annoyance
focus annoyance
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-27 16:30 EDT by Matthias Clasen
Modified: 2009-03-30 05:27 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-30 05:27:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (443 bytes, patch)
2009-03-27 17:15 EDT, Matthias Clasen
no flags Details | Diff

  None (edit)
Description Matthias Clasen 2009-03-27 16:30:29 EDT
Try using keynav to toggle the checkboxes in the list. After each toggle, the focus gets yanked out from under me and to the install button. That is wrong, the focus should stay where I put it. 

What you are trying to achieve here can at least partially be handled by making the install button the default widget for the window.

The offending code is in gpk_update_viewer_reconsider_info:

        /* focus on install button */
        widget = glade_xml_get_widget (glade_xml, "button_install");
        gtk_window_set_focus (GTK_WINDOW(main_window), widget);
Comment 1 Matthias Clasen 2009-03-27 17:15:07 EDT
Created attachment 337062 [details]
patch

default widget does not really help after all, since most focus locations in the dialog eat enter anyway. But this is still the right thing to do. The focus belongs to the user.
Comment 2 Richard Hughes 2009-03-30 05:27:29 EDT
commit 56a8ddabd9db2a19df6502e63c4b34d752d78762
Author: Matthias Clasen <mclasen@redhat.com>
Date:   Mon Mar 30 10:24:50 2009 +0100

    bugfix: don't set the default widget to the install button when we reconsider. Fixes rh#492645

Note You need to log in before you can comment on or make changes to this bug.