Bug 492667 - Internet does not work even though I seem correctly connected
Internet does not work even though I seem correctly connected
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
low Severity high
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-27 18:23 EDT by MirceaKitsune
Modified: 2009-11-10 20:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 20:06:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description MirceaKitsune 2009-03-27 18:23:30 EDT
- Description of problem:

After just installing Fedora 10 I have no internet although all network settings are configured correctly for internet to work.

Basically I successfully manage to start and adjust all Network settings as they should be, and as far as all menus regarding networking are concerned I am correctly connected and internet is up and working. However no application can really connect and no browser, chat application or anything else actually works.

I have checked all menus so I'm sure I haven't forgotten any offline mode anywhere. The Network tray icon shows me as fully connected and running as well, and clicking the Connection Info in it shows my correct MAC address and auto-obtained IP address (same as in Windows which means it gets my IP correctly). If I write 'ifconfig' in a console I get a list with my network settings, IP address and everything else which to me seems as a successful info message not pointing out any failures.

I have also tried disabling the firewall and it's not that either. Also if I try to ping any IP address other then 127.0.0.1 the console instantly prints a message saying something like "Cannot reach network / Cannot connect to network".

- Steps to Reproduce:

Very likely hardware dependent (network card).

- Actual results:

Although every single menu and setting shows me as connected, internet does not work in any application.

- Additional info:

My network card is a Realtek RTL8168/8111 PCI-E Gigabit Ethernet NIC (motherboard integrated). Fedora 10 with KDE 4.
Comment 1 Andre Robatino 2009-03-28 04:59:34 EDT
This is probably broken DNS lookup due to bug #459756.  If you can update glibc, you should have a working system.  Try going into System/Administration/Network/DNS, and for Primary DNS and Secondary DNS, put 208.67.222.222 and 208.67.220.220, resp. (these are the opendns.org nameservers, which worked for my father when he had the same problem).  These settings will probably not survive a reboot, but that's okay since you just need to get DNS working temporarily so you can update out of the problem.
Comment 2 MirceaKitsune 2009-03-28 09:45:22 EDT
Trying the DNS addresses doesn't change anything, even after restarting the connection with them (doesn't survive between logins yeah).
Comment 3 Andre Robatino 2009-03-28 09:56:26 EDT
You could try manually downloading the latest glibc from

http://download.fedora.redhat.com/pub/fedora/linux/updates/10/

on another machine and save it to a thumb drive, and then using rpm -Uvh to apply it on your F10 box.  I don't know offhand if there are other dependencies to be updated as well.
Comment 4 Andre Robatino 2009-03-28 10:04:30 EDT
Check /var/log/rpmpkgs to see which glibc packages you currently have installed.
Comment 5 Dan Williams 2009-04-08 21:35:37 EDT
What's the output of the 'nm-tool' command when the problem occurs?
Comment 6 Dan Williams 2009-11-10 20:06:35 EST
Please re-open if latest Fedora updates don't fix it, or if you can grab the output of 'nm-tool' when the problem appears.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.