Bug 49267 - Error running aspell/ispell from within Emacs
Summary: Error running aspell/ispell from within Emacs
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: aspell   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Eido Inoue
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-17 15:41 UTC by Torsten Schuetze
Modified: 2007-04-18 16:34 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-23 16:29:52 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
aspell problem test case (11.04 KB, text/plain)
2002-07-15 17:10 UTC, Need Real Name
no flags Details

Description Torsten Schuetze 2001-07-17 15:41:18 UTC
I have an american text in Emacs, select the american dictionary and check
the whole buffer. After some steps I get 

Ispell misalignment: word `GZ' point 10288; probably incompatible versions

Since the command line interface for aspell is horrible I can't check my
texts anymore. With the old ispell from RedHat 6.2 everything was okay.
Meanwhile I upgraded to

aspell-0.33.6.3-1.src.rpm
aspell-de-0.1.1-9.src.rpm
automake-1.4p4-2.src.rpm
libtool-1.4-6.src.rpm
libtool-libs13-1.3.5-1.src.rpm
pspell-0.12.2-2.src.rpm

from rawhide, but the error does not vanish. Are there any other frontends
to aspell in RH7.1?

Comment 1 Trond Eivind Glomsrxd 2001-07-23 15:45:52 UTC
Do you have an example file? It doesn't happen for me...

Also, note that the aspell you downloaded has a new TUI.

Comment 2 Torsten Schuetze 2001-07-24 07:30:20 UTC
Do you mean text user interface with TUI? This doesn't matter for me since I use
aspell ONLY from within Emacs or XEmacs. The error happens with emacs and with
xemacs, both with RedHat standard configurations (.emacs, site-start.el).  It is
not easy to reproduce the bug with some public documents :-) but I found another
minor bug while checking manual.tex from aspell-.33.6.3.tar.gz

Select american, Check whole buffer: Always press SPC to leave text as it is
Starting new Ispell process...
Spell checking manual.tex using american dictionary...
error skipping s-expressions at point 8869.

Okay, this is one is not a severe bug. I will send you my text to reproduce the
original bug by private mail.

Comment 3 Need Real Name 2002-07-15 17:10:40 UTC
Created attachment 65424 [details]
aspell problem test case

Comment 4 Need Real Name 2002-07-15 17:12:13 UTC
The test case above shohuld exhibit the problem. Open it in emacs, then
spellcheck the buffer. The first time through it goes okay (just leave the
misspelled words unchanged). Then spellcheck the buffer again. You should get an
error that says

ispell-process-line: Ispell misalignment: word `sgml' point 510; probably
incompatible versions

or something similar

Comment 5 Trond Eivind Glomsrxd 2002-07-25 22:06:23 UTC
Can you try it with the limbo beta or newer? I cannot reproduce it. It works here...

Comment 6 Torsten Schuetze 2002-07-26 09:32:20 UTC
I verified the bug under RH 7.3 (including all official patches) and
pspell-0.12.2-8, aspell-devel-0.33.7.1-9, aspell-0.33.7.1-9,
pspell-devel-0.12.2-8, aspell-de-0.1.1-12.  ==> same behaviour as in original
bug report
Then I downloaded aspell-0.33.7.1-14.src.rpm, aspell-de-0.1.1-15.src.rpm,
emacs-21.2-12.src.rpm, pspell-0.12.2-12.src.rpm from rawhide, recompiled them
and installed pspell-devel-0.12.2-12, aspell-0.33.7.1-14,
aspell-devel-0.33.7.1-14, aspell-en-ca-0.33.7.1-14, aspell-de-0.1.1-15,
aspell-en-gb-0.33.7.1-14, pspell-0.12.2-12, emacs-21.2-12, emacs-el-21.2-12. 
When I then try to start aspell (ispell-buffer) in Emacs the aspell process
starts and hangs. So with the new aspell I cannot even check simple texts in
emacs. For the moment, I restored my old configuration. I'm still waiting for a
satisfying solution.

Comment 7 Torsten Schuetze 2002-07-29 07:26:34 UTC
The problems with Emacs and the new aspell binaries reported above had to do
with some old .aspell* files. After removing them, aspell-0.33.7.1-14 from
rawhide works with Emacs. But the original problem remains. Both my original
test file and the test file ch2.tex from jwdeve@cs.wm.edu exhibit the problem.
So we still have no working spellchecker for TeX-documents in Emacs!

Comment 8 Trond Eivind Glomsrxd 2002-07-29 14:46:10 UTC
(priority/severity shouldn't be set by the bug reporter, they're slightly biased...)

OK, so you confirm that it works with Rawhide. Closing.

Comment 9 Torsten Schuetze 2002-07-29 15:26:26 UTC
No, I confirm that Emacs runs with the new aspell from Rawhide but the original
bug remains.

emacs ch2.tex
ispell-buffer
Loading ispell...done
Starting new Ispell process...
Spell checking ch2.tex using default dictionary...
Spell-checking done
Spell checking ch2.tex using default dictionary...
Spell-checking done
ispell-process-line: Ispell misalignment: word `sgml' point 581; probably
incompatible versions

So, the bug is still open (over one year after the first bug report :-()
PS: Severity/Priority setting: I thought that I could accelerate the bug fixing
process in this way. I really hope that this bug is fixed before RH 8.0 is released!

Comment 10 Trond Eivind Glomsrxd 2002-07-29 15:41:10 UTC
The aspell from Rawhide is what is in limbo currently and will be part of future
releases, so it should be fixed?

Comment 11 Torsten Schuetze 2002-07-30 07:57:21 UTC
Yes, the aspell in Limbo still does not work with Emacs and should be fixed.
However, it may be that the bug is not in aspell directly but in the Emacs
ispell interface to aspell. The error message Ispell misalignment: word `...';
probably
incompatible versions is thrown by ispell.el. I just downloaded ispell.el
version 3.5 from http://kdstevens.com/~stevens/ispell-page.html. This is newer
than ispell.el version 3.4 from Emacs 21.2. It claims to better work with aspell.
The new ispell.el seems to work slightly better with aspell but finally the same
bug occurs. It just takes longer. So I would suggest to update ispell.el in
emacs-el for Limbo and to contact Ken Stevens, the author of ispell.el, for
further investigation of the bug. (One thing that seems to be common in all
tests where the bug manisfests is: tex-sources with lots of mathematics).


Comment 12 Eido Inoue 2003-05-23 16:29:52 UTC
this should be resolved with the upgrade to 0.50.


Note You need to log in before you can comment on or make changes to this bug.