Bug 492691 - [BUG][RHEL5.3][RHEL4.7] Please backport and should unconditionally reset "icsk_probes_out@RHEL5 / probes_out@RHEL4" in 0 when receives a packet with ACK flag
[BUG][RHEL5.3][RHEL4.7] Please backport and should unconditionally reset "ics...
Status: CLOSED DUPLICATE of bug 494427
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.3
All Linux
low Severity high
: ---
: ---
Assigned To: Jiri Olsa
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-28 07:16 EDT by Masaki MAENO
Modified: 2009-06-19 06:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-08 10:07:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Masaki MAENO 2009-03-28 07:16:44 EDT
Description of problem:

This is based upon an excellent bug report from Eric Dumazet in "git.kernel.org"

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=4b53fb67e385b856a991d402096379dab462170a

tcp_ack() should clear ->icsk_probes_out even if there are packets
outstanding.  Otherwise if we get a sequence of ACKs while we do have
packets outstanding over and over again, we'll never clear the
probes_out value and eventually think the connection is too sick and
we'll reset it.

Version-Release number of selected component (if applicable):

RHEL5.3 (kernel-2.6.18-128.el5)
RHEL4.7 (kernel-2.6.9-78.EL)

How reproducible:

* Example of problem generation condition:
  - SO_KEEPALIVE is valid.
  - TCP_KEEPIDLE is 1.
  - TCP_KEEPCNT is 1.
  - TCP_KEEPINTVL is 1.

* Example of problem

The kernel sends RST packet because it doesn't reset ->icsk_probes_out
in 0 though the kernel receives a packet with ACK flag (if ->packets_out
isn't 0).

Actual results:

A socket unexpectly close because of RST packet.

Expected results:

A socket keeps operating.
Comment 1 Jiri Olsa 2009-04-08 10:07:57 EDT

*** This bug has been marked as a duplicate of bug 494427 ***
Comment 2 Darren Evans 2009-06-19 05:54:10 EDT
I am unable to view the status of duplicate bug 494427; does anyone know its current status?
Comment 3 Jiri Olsa 2009-06-19 06:19:53 EDT
it is ON_QA in kernel-2.6.18-140.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

Note You need to log in before you can comment on or make changes to this bug.