Bug 492721 - pavucontrol fails to connect to pulseaudio process
pavucontrol fails to connect to pulseaudio process
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: pavucontrol (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-28 17:19 EDT by Jeff Ammons
Modified: 2013-08-18 21:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-22 07:17:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/home/floki/.xsession-errors (2.49 KB, text/plain)
2009-03-30 19:16 EDT, Flóki Pálsson
no flags Details

  None (edit)
Description Jeff Ammons 2009-03-28 17:19:21 EDT
Description of problem: When running Pulseaudio Volume Control from the menu I get an error saying "Connection Failed: Connection Refused." If I run pavucontrol from a terminal, I get this: (pavucontrol:4660): Gtk-CRITICAL **: gtk_main_quit: assertion `main_loops != NULL' failed


Version-Release number of selected component (if applicable): Not sure.

Steps to Reproduce:
1.run pavucontrol
  
Actual results:
(pavucontrol:4660): Gtk-CRITICAL **: gtk_main_quit: assertion `main_loops != NULL' failed

Expected results:
Expect to see audio controls.

Additional info:
I'm running Fedora 11 beta off a live cd.
Comment 1 Lennart Poettering 2009-03-30 10:20:16 EDT
That means PA has not been started. Please provide the contents of ~/.xsession-errors.
Comment 2 Lennart Poettering 2009-03-30 10:21:27 EDT
Oh, and also everything from syslog regarding PA, please.
Comment 3 Flóki Pálsson 2009-03-30 19:16:04 EDT
Created attachment 337258 [details]
/home/floki/.xsession-errors



[floki@flokipa ~]$ pavucontrol

(pavucontrol:14524): Gtk-CRITICAL **: gtk_main_quit: assertion `main_loops != NULL' failed

(pavucontrol:14524): Gtk-CRITICAL **: gtk_main_quit: assertion `main_loops != NULL' failed
[floki@flokipa ~]$
Comment 4 Flóki Pálsson 2009-03-30 19:30:09 EDT
 where is syslog and "regarding PA" 
I am not sure, but I seams to me that this is related to use off ogg123 ( or mpg321 ) and rhythmbox. It helps to log user out.
Comment 5 Lennart Poettering 2009-04-03 12:01:25 EDT
/var/log/syslog is the system log. All lines that mention pulseaudio I'd like to have a peek on.
Comment 6 Jeff Ammons 2009-04-03 12:46:22 EDT
Sorry I haven't responded. I was testing this at a LUG meeting and I don't have a disk with Fedora on it at the moment. I'm downloading one so I'll try to get this info to you today or tomorrow.

Thanks for the help.
Comment 7 Jeff Ammons 2009-04-04 03:01:45 EDT
Alright, got the live-cd going. I tried immediately after boot and the sound controller worked. However, I just tried it again about 10 minutes later and I'm getting the same error message as I had gotten before. All I've done is open three things: Firefox, gnome-terminal, and add/remove software.

Here's the stuff you've requested:
[liveuser@sabretooth ~]$ cat ~/.xsession-errors 
imsettings information
==========================
Is DBus enabled: yes
Is imsettings enabled: yes
Is GTK+ supported: yes
Is Qt supported: no
DESKTOP_SESSION: gnome
DISABLE_IMSETTINGS: 
IMSETTINGS_DISABLE_DESKTOP_CHECK: 
DBUS_SESSION_BUS_ADDRESS: unix:abstract=/tmp/dbus-ZYUdUFKpxm,guid=1990ce6cbb3ee491bcd0847349d73932
GTK_IM_MODULE: 
QT_IM_MODULE: xim
XMODIFIERS: @im=imsettings
IMSETTINGS_MODULE: none
IMSETTINGS_INTEGRATE_DESKTOP: yes

Traceback (most recent call last):
  File "/usr/sbin/sabayon-apply", line 43, in <module>
    from sabayon import errors
ImportError: cannot import name errors
_IceTransmkdir: Owner of /tmp/.ICE-unix should be set to root
GNOME_KEYRING_SOCKET=/tmp/keyring-EFU79e/socket
SSH_AUTH_SOCK=/tmp/keyring-EFU79e/socket.ssh
GNOME_KEYRING_PID=3478
Window manager warning: Failed to read saved session file /home/liveuser/.config/metacity/sessions/10775a13606aa5447f123884166321625600000032710022.ms: Failed to open file '/home/liveuser/.config/metacity/sessions/10775a13606aa5447f123884166321625600000032710022.ms': No such file or directory
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
gnome-session[3271]: WARNING: Application 'gnome-panel.desktop' failed to register before timeout

** (gnome-settings-daemon:3473): WARNING **: NumLock remembering disabled because hostname is set to "localhost"
** (gnome-volume-control-applet:3526): DEBUG: Disabling debugging
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
I: caps.c: Dropping root privileges.
I: caps.c: Limited capabilities successfully to CAP_SYS_NICE.
N: main.c: Called SUID root and real-time and/or high-priority scheduling was requested in the configuration. However, we lack the necessary privileges:
N: main.c: We are not in group 'pulse-rt', PolicyKit refuse to grant us the requested privileges and we have no increase RLIMIT_NICE/RLIMIT_RTPRIO resource limits.
N: main.c: For enabling real-time/high-priority scheduling please acquire the appropriate PolicyKit privileges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
Initializing nautilus-gdu extension

** (gnome-panel:3483): WARNING **: panel-applet-frame.c:1288: failed to load applet OAFIID:TomboyApplet:
(null)
** Message: <info>  No keyring secrets found for Auto X-Mansion/802-11-wireless-security; asking user.


(nm-applet:3512): Gtk-CRITICAL **: gtk_size_group_remove_widget: assertion `g_slist_find (size_group->widgets, widget)' failed


** (nm-applet:3512): WARNING **: applet-device-wifi.c.1539 (get_secrets_dialog_response_cb): canceled
gnome-session[3271]: WARNING: Unable to find watch for alarm 12582917
gnome-session[3271]: WARNING: Unable to find watch for alarm 12582918

(pavucontrol:3919): Gtk-CRITICAL **: gtk_main_quit: assertion `main_loops != NULL' failed

(pavucontrol:3919): Gtk-CRITICAL **: gtk_main_quit: assertion `main_loops != NULL' failed


----------------
I didn't have a syslog file, but here's all the pulseaudio mentions in my /var/log files:
[root@sabretooth liveuser]# grep -R "pulseaudio" /var/log
/var/log/messages:Apr  4 06:41:07 localhost pulseaudio[3482]: main.c: Called SUID root and real-time and/or high-priority scheduling was requested in the configuration. However, we lack the necessary privileges:
/var/log/messages:Apr  4 06:41:07 localhost pulseaudio[3482]: main.c: We are not in group 'pulse-rt', PolicyKit refuse to grant us the requested privileges and we have no increase RLIMIT_NICE/RLIMIT_RTPRIO resource limits.
/var/log/messages:Apr  4 06:41:07 localhost pulseaudio[3482]: main.c: For enabling real-time/high-priority scheduling please acquire the appropriate PolicyKit privileges, or become a member of 'pulse-rt', or increase the RLIMIT_NICE/RLIMIT_RTPRIO resource limits for this user.
/var/log/messages:Apr  4 06:41:26 localhost pulseaudio[3534]: pid.c: Daemon already running.


Thanks.
Comment 8 Lennart Poettering 2009-04-10 10:40:33 EDT
Jeff, that output looks perfectly fine.

Hmm, you say that in that very session pavucontrol failed to start with 'Connection refused"?

Could you please run PA in a terminal like 'pulseaudio -vvvv' in a terminal, and then do your stuff to reproduce the issue? If you manage to reproduce, please include the output that pulseaudio -vvvv produced here in the bug report. You might need to stop pa first with pulseaudio -k.
Comment 9 Jeff Ammons 2009-04-21 21:37:32 EDT
So I tried for a while last night to replicate this after running pulseaudio with the -vvvv flags and failed, it was working fine, which I suppose is good. I'll try again when I get some free time.
Comment 10 Lennart Poettering 2009-04-22 07:17:14 EDT
Ok, will hence close now. If you manage to reproduce feel free to reopen.
Comment 11 The PowerTool 2013-08-18 21:02:15 EDT
I ran into what appeared to be this exact problem.  I followed the detail, above, (mainly killing PA and running -vvvv in terminal) and the problem vanished.  I wasn't sure whether to even document my experience.  As I am no longer experiencing the problem no follow-up is required.  The main reason I'm documenting this is because I'm seeing it here:

]$ uname -a
Linux p7-1456c.localdomain 3.10.4-100.fc18.x86_64 #1 SMP Thu Aug 1 21:13:27 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
]$ cat /etc/redhat-release 
Fedora release 18 (Spherical Cow)

Here's my session.log: http://pastebin.com/E1JJzhDj
-I hope it helps.

Note You need to log in before you can comment on or make changes to this bug.