Bug 492746 - [epiphany] cannot edit URL in address field after selecting it with the mouse
[epiphany] cannot edit URL in address field after selecting it with the mouse
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-29 04:53 EDT by Joachim Frieben
Modified: 2009-03-31 13:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-31 13:47:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of epiphany showing a highlighted URL and misplaced text input (52.78 KB, image/png)
2009-03-29 04:53 EDT, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2009-03-29 04:53:31 EDT
Created attachment 337153 [details]
Screenshot of epiphany showing a highlighted URL and misplaced text input

Description of problem:
Trying to edit a URL in the address field after selecting it with the mouse has no effect. The focus seems to be elsewhere, e.g. in some text field of the page as shown in the attached screenshot. On the other hand, the <backspace> key still works and allows to remove the undesired portion of the URL. Herafter, the new URL or parts of it can be appended in the text field.

Version-Release number of selected component (if applicable):
epiphany-2.26.0-2.fc11.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Enter URL in address field and load target page.
2. Select URL with the mouse.
3. Enter a new URL.
  
Actual results:
None.

Expected results:
New URL appears in the address field as it gets typed.

Additional info:
- This issue already affects GNOME 2.24.x as included in F10.
- midori-0.1.4-2.fc11.x86_64 behaves as expected in this respect.
- Changing the keyboard layout from evdev to a fixed one has no effect.
Comment 1 Joachim Frieben 2009-03-30 03:40:15 EDT
Just checked for the F10 i686 live CD after installing epiphany-2.24.3-4.fc10.i386, and in this case, the address bar actually works as expected. I thus have to revoke my earlier comment under "Additional info". It appears that GNOME 2.24.x is not affected.
Comment 2 Joachim Frieben 2009-03-30 05:28:44 EDT
A striking test case is the Hotmail service at http://login.live.com - when entering "Windows Live ID" or password, then the text appears at the beginning of the address bar instead of in the corresponding text fields. Any hint how to proceed further is highly welcome.

Note You need to log in before you can comment on or make changes to this bug.