Bug 492837 - Internal system error on package installation
Internal system error on package installation
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: gnome-packagekit (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-30 06:14 EDT by Christoph Wickert
Modified: 2014-09-22 11:56 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-07 16:46:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sgireeshmail: needinfo-


Attachments (Terms of Use)

  None (edit)
Description Christoph Wickert 2009-03-30 06:14:28 EDT
Description of problem:
Trying to install a couple of packages with gnome-packagekit, I'm getting an internal system error.

Version-Release number of selected component (if applicable):
gnome-packagekit-0.3.14-1.fc10.i386

How reproducible:
sometimes, say one out of ten times

Steps to Reproduce:
1. Fresh install with all updates applied
2. Try to install something with gnome-packagekit
  
Actual results:
gpk-application hangs, nothing happens: No cpu load, no network traffic. After a while an error message appears:

An internal system error occurred
A problem that we were not expecting has occurred.
Please report this bug in your distribution bug tracker with the error description.
More details:
<module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 2311, in main
    backend.dispatcher(sys.argv[1:])
  File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line 600, in dispatcher
    self.dispatch_command(args[0], args[1:])
  File : /usr/lib/python2.5/site-packages/packagekit/backend.py, line 517, in dispatch_command
    self.install_packages(pkgs)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 1217, in install_packages
    pkg, inst = self._findPackage(package)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 745, in _findPackage
    pkgs = self.yumbase.pkgSack.searchNevra(name=n, epoch=e, ver=v, rel=r, arch=a)
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 592, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File : /usr/lib/python2.5/site-packages/yum/__init__.py, line 435, in _getSacks
    self.repos.populateSack(which=repos)
  File : /usr/lib/python2.5/site-packages/yum/repos.py, line 251, in populateSack
    sack.populate(repo, mdtype, callback, cacheonly)
  File : /usr/lib/python2.5/site-packages/yum/yumRepo.py, line 174, in populate
    misc.bunzipFile(db_fn, db_un_fn)
  File : /usr/lib/python2.5/site-packages/yum/misc.py, line 589, in bunzipFile
    s_fn = bz2.BZ2File(source, 'r')
Comment 1 Richard Hughes 2009-03-30 06:25:10 EDT
I've never seen this error before. If you do "yum clean all" and then retry, does this fix things?
Comment 2 Christoph Wickert 2009-03-30 07:27:00 EDT
I did not try, I used "Refresh package lists" from the menu and the error disappeared.
Comment 3 Gireesh Sreekantan 2009-04-07 16:46:28 EDT
Hi Christoph,
From your last update, it looks like things are back to normal. We consider that a reasonable amount of time has passed between the first time the bug occurred and now. Since the bug is not reproducible again, I am closing this bug out now.

In case you face the similar issue again, please open a bug report with the exact steps you did to reproduce it. It would be more helpful, if you can also try the command from comment #1 and also update us if that worked on the new bug if you open one.


-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 4 Christoph Wickert 2009-04-07 20:10:03 EDT
(In reply to comment #3)
> Hi Christoph,
> From your last update, it looks like things are back to normal. We consider
> that a reasonable amount of time has passed between the first time the bug
> occurred and now. 

You call 5 days a reasonable amount of time? Given the fact that you only refresh you package list once a day the package lists have been refreshed only four times.

> Since the bug is not reproducible again, I am closing this bug out now.

Gireesh, I doubt that this kind of bugzapping is really helpful. Bugzilla is for tracking bugs and not for housekeeping.

> In case you face the similar issue again, please open a bug report with the
> exact steps you did to reproduce it. 

I think I already gave a detailed description, what exactly is missing in your opinion? Why did you flag the bug NEEDINFO if you closed it anyway? And why should I open a new bug? It can better be tracked here because this bug marks it's first appearance.

The error message tells the user to report the bug to the developers and that's what I did. Richard said that he has never seen this bug before, so this should be investigated or even better get fixed (e.g. by automatically making gpk refresh the package lists if there is something wrong with them).

> It would be more helpful, if you can also
> try the command from comment #1 and also update us if that worked on the new
> bug if you open one.

Of course 'yum clean all' will fix the bug because afterwards you have to refresh software sources again - and this is what packagekit did when I selected 'Refresh package lists' from the menu. Are you really sure you know what's going on here?

Note You need to log in before you can comment on or make changes to this bug.