Bug 492845 - alacarte doesn't modify sub items in system menu.
alacarte doesn't modify sub items in system menu.
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: alacarte (Show other bugs)
5.2
All Linux
low Severity medium
: rc
: ---
Assigned To: Jasper St. Pierre
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-30 07:19 EDT by Tru Huynh
Modified: 2014-08-26 22:58 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:01:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 205257 None None None Never
GNOME Desktop 355828 None None None Never
CentOS 3452 None None None Never

  None (edit)
Description Tru Huynh 2009-03-30 07:19:53 EDT
Description of problem:
alacarte doesn't modify sub items in system menu.

Version-Release number of selected component (if applicable):
alacarte-0.10.0-1.fc6.noarch


How reproducible:
always

Steps to Reproduce:
1. click system menu on alacarte
2. check or uncheck item
3.
  
Actual results:
nothing

Expected results:
allow changes

Additional info:

starting alacarte from the command line and try to change a item on the sytem menu yields:
Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/Alacarte/MainWindow.py", line 372, in on_item_tree_show_toggled
    self.editor.setVisible(item, False)
  File "/usr/lib/python2.4/site-packages/Alacarte/MenuEditor.py", line 208, in setVisible
    menu_xml = self.__getXmlMenu(self.__getPath(item), dom, dom)
  File "/usr/lib/python2.4/site-packages/Alacarte/MenuEditor.py", line 475, in __getXmlMenu
    node = self.__addXmlMenuElement(element, name, dom)
  File "/usr/lib/python2.4/site-packages/Alacarte/MenuEditor.py", line 486, in __addXmlMenuElement
    return element.appendChild(node)
  File "/usr/lib64/python2.4/site-packages/_xmlplus/dom/minidom.py", line 1548, in appendChild
    raise xml.dom.HierarchyRequestErr(
xml.dom.HierarchyRequestErr: two document elements disallowed
Comment 1 Amir Caspi 2009-04-07 18:48:21 EDT
Also reproducible in 5.3, since the alacarte package is the same there.
Comment 2 Ralph Angenendt 2010-08-03 06:51:28 EDT
No changes in 5.5 either.
Comment 3 xjtukangshifu 2011-09-27 05:40:42 EDT
No change in 5.6 either.
Comment 4 RHEL Product and Program Management 2014-03-07 07:12:39 EST
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in the  last planned RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX. To request that Red Hat re-consider this request, please re-open the bugzilla via  appropriate support channels and provide additional business and/or technical details about its importance to you.
Comment 5 RHEL Product and Program Management 2014-06-02 09:01:25 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).
Comment 6 Tru Huynh 2014-06-16 08:16:45 EDT
NEEDINFO: what kind of information is requested? bugs is marked closed "WONTFIX".

Note You need to log in before you can comment on or make changes to this bug.