Bug 492864 - rhnmd 5.1.7-1 dependency errors
rhnmd 5.1.7-1 dependency errors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Monitoring (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
wes hayutin
:
Depends On:
Blocks: 463877 486216
  Show dependency treegraph
 
Reported: 2009-03-30 09:00 EDT by wes hayutin
Modified: 2009-09-10 14:15 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 14:15:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-03-30 09:00:27 EDT
Description of problem:

[root@fjs-0-18 ~]# up2date rhnmd

Fetching Obsoletes list for channel: rhel-i386-as-4...

Fetching Obsoletes list for channel: rhn-tools-rhel-4-as-i386...

Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
rhnmd                                   5.1.7          1.el4sat          i386  


Testing package set / solving RPM inter-dependencies...
There was a package dependency problem. The message was:

Unresolvable chain of dependencies:
nocpulse-common  2.1.8-1.el4sat          requires perl(IO::AtomicFile)


The following packages were added to your selection to satisfy dependencies:
Package                                Required by
----------------------------------------------------------------------------

[root@fjs-0-18 ~]# 



This action will be executed after 03/30/09 8:48:42 AM EDT.

This action's status is: Failed.
The client picked up this action on 03/30/09 8:48:43 AM EDT.
The client completed this action on 03/30/09 8:48:54 AM EDT.
Client execution returned "Failed: packages requested raised dependency problems" (code 18)
Packages Scheduled:

    * rhnmd-5.1.7-1.el4sat

Dependency errors encountered:

    * nocpulse-common-2.1.8-1.el4sat requires perl(IO::AtomicFile)
Comment 1 wes hayutin 2009-03-30 15:28:09 EDT
nocpulse-common-2.1.8-1.el5sat.noarch from rhn-tools-rhel-i386-server-5 has depsolving problems
  --> Missing Dependency: perl(IO::AtomicFile) is needed by package nocpulse-common-2.1.8-1.el5sat.noarch (rhn-tools-rhel-i386-server-5)
Error: Missing Dependency: perl(IO::AtomicFile) is needed by package nocpulse-common-2.1.8-1.el5sat.noarch (rhn-tools-rhel-i386-server-5)
Comment 2 Miroslav Suchý 2009-03-31 09:33:52 EDT
Nice catch.
Filed rel-eng ticket #38558 to include perl-IO-stringy in rhn tools channel. This one package will satisfy this dependecy (just tried).
Comment 3 Miroslav Suchý 2009-04-06 05:18:13 EDT
It is there:
$ ls /mnt/redhat/devel/candidate-trees/RHN-Tools-5.3.0-RHEL5-re20090403.2/i386/i386/RHNTools/perl*
/mnt/redhat/devel/candidate-trees/RHN-Tools-5.3.0-RHEL5-re20090403.2/i386/i386/RHNTools/perl-IO-stringy-2.109-11.el5.noarch.rpm
Moving ON_QA
Comment 4 wes hayutin 2009-04-07 11:34:56 EDT
Fetching rpm headers...
########################################

Name                                    Version        Rel     
----------------------------------------------------------
rhnmd                                   5.1.7          1.el4sat          i386  


Testing package set / solving RPM inter-dependencies...
########################################
nocpulse-common-2.1.8-1.el4 ########################## Done.                   
perl-DBI-1.40-9.i386.rpm:   ########################## Done.                   
perl-HTML-Parser-3.55-1.el4 ########################## Done.                   
perl-IO-stringy-2.109-11.el ########################## Done.                   
perl-URI-1.30-4.noarch.rpm: ########################## Done.                   
perl-libwww-perl-5.79-5.noa ########################## Done.                   
rhnmd-5.1.7-1.el4sat.i386.r ########################## Done.                   
perl-HTML-Tagset-3.03-30.no ########################## Done.                   
Preparing              ########################################### [100%]

Installing...
   1:perl-HTML-Tagset       ########################################### [100%]
   2:perl-HTML-Parser       ########################################### [100%]
   3:perl-URI               ########################################### [100%]
   4:perl-libwww-perl       ########################################### [100%]
   5:perl-IO-stringy        ########################################### [100%]
   6:perl-DBI               ########################################### [100%]
   7:nocpulse-common        ########################################### [100%]
   8:rhnmd                  ########################################### [100%]
The following packages were added to your selection to satisfy dependencies:

Name                                    Version        Release
--------------------------------------------------------------
nocpulse-common                         2.1.8          1.el4sat            
perl-DBI                                1.40           9                   
perl-HTML-Parser                        3.55           1.el4               
perl-IO-stringy                         2.109          11.el4              
perl-URI                                1.30           4                   
perl-libwww-perl                        5.79           5                   
perl-HTML-Tagset                        3.03           30                  

Total                                                                           1.6 MB/s | 2.9 MB     00:01     
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing     : perl-URI                                        [ 1/14] 
  Installing     : perl-HTML-Tagset                                [ 2/14] 
  Installing     : perl-IO-stringy                                 [ 3/14] 
  Installing     : apr                                             [ 4/14] 
  Installing     : perl-HTML-Parser                                [ 5/14] 
  Installing     : postgresql-libs                                 [ 6/14] 
  Installing     : apr-util                                        [ 7/14] 
  Installing     : httpd                                           [ 8/14] 
  Installing     : perl-DBI                                        [ 9/14] 
  Installing     : perl-Compress-Zlib                              [10/14] 
  Installing     : perl-libwww-perl                                [11/14] 
  Installing     : nocpulse-common                                 [12/14] 
  Updating       : rhnmd                                           [13/14] 
  Cleanup        : rhnmd                                           [14/14] 
warning: /opt/nocpulse/.ssh/authorized_keys saved as /opt/nocpulse/.ssh/authorized_keys.rpmsave

Dependency Installed: apr.i386 0:1.2.7-11 apr-util.i386 0:1.2.7-7.el5 httpd.i386 0:2.2.3-22.el5 nocpulse-common.noarch 0:2.1.8-1.el5sat perl-Compress-Zlib.i386 0:1.42-1.fc6 perl-DBI.i386 0:1.52-2.el5 perl-HTML-Parser.i386 0:3.55-1.fc6 perl-HTML-Tagset.noarch 0:3.10-2.1.1 perl-IO-stringy.noarch 0:2.109-11.el5 perl-URI.noarch 0:1.35-3 perl-libwww-perl.noarch 0:5.805-1.1.1 postgresql-libs.i386 0:8.1.11-1.el5_1.1
Updated: rhnmd.i386 0:5.1.7-1.el5sat
Complete!
Comment 5 Jan Pazdziora 2009-09-07 07:20:04 EDT
It looks like the dependencies have changed as neither perl-IO-stringy nor nocpulse-common seems to be pulled into the transaction:

[root@vmware146 ~]# rpm -q perl-IO-stringy rnhmd
package perl-IO-stringy is not installed
package rnhmd is not installed
[root@vmware146 ~]# up2date rhnmd

Fetching Obsoletes list for channel: rhel-i386-as-4...

Fetching Obsoletes list for channel: rhn-tools-rhel-4-as-i386...

Fetching rpm headers...
########################################

Name                                    Version              Rel               Arch
----------------------------------------------------------------------------------------
rhnmd                                   5.3.0               4.el4sat            i386  


Testing package set / solving RPM inter-dependencies...
########################################
rhnmd-5.3.0-4.el4sat.i386.r ########################## Done.                   
Preparing              ########################################### [100%]

Installing...
   1:rhnmd                  ########################################### [100%]
[root@vmware146 ~]# 
[root@vmware146 ~]# rpm -q nocpulse-common
package nocpulse-common is not installed
[root@vmware146 ~]# 

Moving to RELEASE_PENDING, please shout if this is not to the expected state.
Comment 6 Miroslav Suchý 2009-09-07 07:49:26 EDT
Yes, rhnmd do not (again) require nocpulse-common. Which means it neither require perl-IO-stringy.
Comment 7 Brandon Perkins 2009-09-10 14:15:19 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.