Bug 492940 - 2.6.29 -> crc error -- System halted
2.6.29 -> crc error -- System halted
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
10
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-30 16:40 EDT by Orion Poplawski
Modified: 2009-04-01 16:53 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 16:53:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2009-03-30 16:40:34 EDT
Description of problem:

Recent 2.6.29 fc10 kernels from koji fail to boot on one of my machines with (quiet turned off):

Probing EDD (edd=off) to disable... ok


  crc error

   --  System halted


And that is it.

Adding edd=off simply removes the first line.

2.6.29-0.64.rc8.git4.fc10.i686 works, but 2.6.29-3.fc10 and 2.6.29-10.fc10 don't.

# lspci
00:00.0 Host bridge: Intel Corporation 82865G/PE/P DRAM Controller/Host-Hub Interface (rev 02)
00:01.0 PCI bridge: Intel Corporation 82865G/PE/P PCI to AGP Controller (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev c2)
00:1f.0 ISA bridge: Intel Corporation 82801EB/ER (ICH5/ICH5R) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801EB/ER (ICH5/ICH5R) IDE Controller (rev02)
00:1f.3 SMBus: Intel Corporation 82801EB/ER (ICH5/ICH5R) SMBus Controller (rev 02)
00:1f.5 Multimedia audio controller: Intel Corporation 82801EB/ER (ICH5/ICH5R) AC'97Audio Controller (rev 02)
01:00.0 VGA compatible controller: ATI Technologies Inc RV350 AS [Radeon 9550]
01:00.1 Display controller: ATI Technologies Inc RV350 AS [Radeon 9550] (Secondary)
02:05.0 Ethernet controller: Marvell Technology Group Ltd. 88E8001 Gigabit Ethernet Controller (rev 13)
02:0a.0 Bridge: PLX Technology, Inc. Device 2173 (rev 01)

# cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 4
model name      : Intel(R) Pentium(R) 4 CPU 2.40GHz
stepping        : 1
cpu MHz         : 2399.940
cache size      : 1024 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 5
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe constant_tsc up pebs bts pni dtes64monitor ds_cpl cid xtpr
bogomips        : 4797.84
clflush size    : 64
power management:
Comment 1 Chuck Ebbert 2009-04-01 11:33:55 EDT
Looks like the initrd or the kernel image is corrupted. Does uninstalling and reinstalling the kernel fix it? Does rpm --verify <kernel-pkgname> show any problems? Does removing 'quiet' from the boot options show any additional information?
Comment 2 Orion Poplawski 2009-04-01 16:53:45 EDT
It has happened with two 2.6.29 kernels now -3 and -10.

quiet is off.  I think this is before it even gets to the initrd.

rpm --verify does show errors:

# rpm --verify kernel-2.6.29-10.fc10.i686
..5.....    /boot/vmlinuz-2.6.29-10.fc10.i686
..5.....    /lib/modules/2.6.29-10.fc10.i686/kernel/drivers/atm/horizon.ko
..5.....    /lib/modules/2.6.29-10.fc10.i686/kernel/drivers/char/tpm/tpm_bios.ko
..5.....    /lib/modules/2.6.29-10.fc10.i686/kernel/drivers/infiniband/hw/mthca/ib_mthca.ko
..5.....    /lib/modules/2.6.29-10.fc10.i686/kernel/drivers/input/touchscreen/htcpen.ko
..5.....    /lib/modules/2.6.29-10.fc10.i686/kernel/drivers/isdn/hisax/hisax.ko

Re-installed, no checksum errors:

# rpm --verify kernel-2.6.29-10.fc10.i686
.......T    /lib/modules/2.6.29-10.fc10.i686/modules.alias.bin
.......T    /lib/modules/2.6.29-10.fc10.i686/modules.dep.bin
.......T    /lib/modules/2.6.29-10.fc10.i686/modules.symbols.bin

Rebooted fine.

Maybe hardware troubles though memtest86+ and smartctl show everything as clean.

Note You need to log in before you can comment on or make changes to this bug.