Bug 492980 - API docs should specify that last_modified_date is only returned for published errata
API docs should specify that last_modified_date is only returned for publishe...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API (Show other bugs)
530
All Linux
low Severity low
: ---
: ---
Assigned To: Brad Buckingham
Sayli Karmarkar
:
Depends On:
Blocks: 456996
  Show dependency treegraph
 
Reported: 2009-03-30 21:58 EDT by Sayli Karmarkar
Modified: 2015-03-22 21:09 EDT (History)
2 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:55:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sayli Karmarkar 2009-03-30 21:58:53 EDT
Description of problem:
errata.getDetails doc says:

"Returns:

    * struct - erratum
          o string "issue_date"
          o string "update_date"
          o string "last_modified_date"
          o string "description"
          o string "synopsis"
          o string "topic"
          o string "references"
          o string "notes"
          o string "type"
"


If I create a custon errata, without publishing, I can see:

>>> server.errata.getDetails(key, "foobar")
{'update_date': '3/31/09', 'issue_date': '3/31/09', 'description': 'foobar', 'notes': '', 'topic': 'foobar', 'synopsis': 'foobar', 'references': '', 'type': 'Bug Fix Advisory'}

After publishing,
>>> server.errata.getDetails(key, "foobar")
{'update_date': '3/31/09', 'issue_date': '3/31/09', 'description': 'foobar', 'notes': '', 'last_modified_date': '2009-03-31 01:43:22.0', 'topic': 'foobar', 'synopsis': 'foobar', 'references': '', 'type': 'Bug Fix Advisory'}


So, if this is expected behavior we should probably write a note in api doc saying last_modified_date is not returned for unpublished errata, else we should make both consistent.
Comment 1 Brad Buckingham 2009-04-01 10:05:54 EDT
git commit: b56536d715922ac98eca9fcb77a428a4a976eb74

For clarification, updated the doc for last_modified_date to be:
#  string "last_modified_date" - This date is only included for published erratum and it represents the last time the erratum was modified. 

Also, added release, product and solution to the result.  Since these values can be set with errata.setDetails, it would be useful to be able to also retrieve them.
Comment 2 Sayli Karmarkar 2009-04-07 17:40:48 EDT
verified and updated testcase.
Comment 3 Jeff Browning 2009-08-27 02:42:56 EDT
Tested on dhcp77-153.rhndev.redhat.com
Comment 4 Brandon Perkins 2009-09-10 15:55:16 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.