Bug 493040 - Update size and status
Update size and status
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: PackageKit (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 08:28 EDT by Michael Monreal
Modified: 2009-04-15 17:06 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-15 12:23:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the Problem (33.31 KB, image/png)
2009-03-31 08:30 EDT, Michael Monreal
no flags Details

  None (edit)
Description Michael Monreal 2009-03-31 08:28:29 EDT
After rawhide was unfrozen a few days ago there were a lot of updates. I let a full upgrade run and somehow managed to crash X during this.

After restarting PackageKit updater I noticed some packages now had Size "0 bytes". I was confused but concluded that "Size" means "Size to download". However, for packages that were newly downloaded during this session, the Size field still showed the "to download" Size even after download was done.

IMHO showing "0 bytes" is not a good idea. I agree that the "left to download" size is what matters. I also find it strange that packages which are already downloaded still show the icon used for "Downloading package" and wonder if the Status column really needs to show that icon anyway (it's also shown on the bottom so this seems to be a duplication)

Propoosal: unify the Size and Status columns to one "To Download" column. This column would contain:
- for not downloaded packages: the package size
- for downloaded packages: nothing
- for downloading packages: xMB of $packagesize and maybe the prograss bar

This is way simpler and does not even miss any of the information currently displayed.
Comment 1 Michael Monreal 2009-03-31 08:30:45 EDT
Created attachment 337297 [details]
Screenshot of the Problem

In the screenshot the first package was downloaded during the active session and the next packages were already cached from the last (failed) session.
Comment 2 Richard Hughes 2009-04-15 12:23:07 EDT
Should be fixed in yesterdays snapshot. Thanks.
Comment 3 Michael Monreal 2009-04-15 17:06:05 EDT
Right. I would still prefer to have only one (merged) column but I guess this is a matter of taste. The current version seems to work very well.

Note You need to log in before you can comment on or make changes to this bug.