Bug 493062 - "Battery may be broken" alert appears after updating to DeviceKit-power-007-2.fc11.x86_64
"Battery may be broken" alert appears after updating to DeviceKit-power-007-2...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: DeviceKit-power (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
: 493297 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 10:12 EDT by Tom London
Modified: 2009-04-01 10:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-01 10:28:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Alert with "69% warning" (33.34 KB, image/png)
2009-03-31 10:12 EDT, Tom London
no flags Details
Output of devkit -s power_supply & devkit-power -d (2.65 KB, text/plain)
2009-03-31 13:35 EDT, Tomislav Vujec
no flags Details

  None (edit)
Description Tom London 2009-03-31 10:12:00 EDT
Description of problem:
After upgrading to DeviceKit-power-007-2.fc11.x86_64, each time I login I get an alert telling me that my battery is broken ("low capacity (69%) ...").

System is (one-two months old) Thinkpad X200.

I see no messages in /var/log/messages, nor in ~/.xsession-errors.

If I manually start gnome-power-manager, I get the same alert.  Running g-p-m with "--no-daemon --verbose --debug" produces no output:

[tbl@tlondon ~]$ gnome-power-manager --no-daemon --verbose --debug
^C
[tbl@tlondon ~]$ 


Version-Release number of selected component (if applicable):
DeviceKit-power-007-2.fc11.x86_64

How reproducible:
Every time....

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tom London 2009-03-31 10:12:53 EDT
Created attachment 337309 [details]
Alert with "69% warning"

Screen shot of alert.....
Comment 2 Tom London 2009-03-31 10:13:50 EDT
Forgot version of g-p-m:

gnome-power-manager-2.26.0-1.fc11.x86_64
Comment 3 Tom London 2009-03-31 10:33:27 EDT
Also forgot to mention:  reverting to DeviceKit-power-006-3.fc11.x86_64 "makes it work again".

With DeviceKit-power-006-3.fc11.x86_64 (and a reboot), the applet returns to the panel, and I no longer get the "69% alerts".
Comment 4 Tomislav Vujec 2009-03-31 13:35:22 EDT
Created attachment 337350 [details]
Output of devkit -s power_supply & devkit-power -d

It is also happening here. It seems that the proper data is exported from kernel, through hal up to DeviceKit, but for some reason, DeviceKit-power misses it. Output of both devkit -s power_supply & devkit-power -d is attached.
Comment 5 Richard Hughes 2009-04-01 06:06:24 EDT
Should fix things: http://koji.fedoraproject.org/koji/taskinfo?taskID=1269589
Comment 6 Richard Hughes 2009-04-01 06:32:02 EDT
*** Bug 493297 has been marked as a duplicate of this bug. ***
Comment 7 Tomislav Vujec 2009-04-01 10:20:42 EDT
Version 008-0.1.20090401git.fc11 works. All properties are correctly available. I think that ticket can be closed.
Comment 8 Tom London 2009-04-01 10:28:27 EDT
Yeah... "works for me".

Closing Rawhide.

Note You need to log in before you can comment on or make changes to this bug.