Bug 493063 - Provide some way to turn off daily logwatch
Provide some way to turn off daily logwatch
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: logwatch (Show other bugs)
15
All Linux
low Severity low
: ---
: ---
Assigned To: Jan Synacek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 10:16 EDT by Ed Avis
Modified: 2012-03-07 04:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-07 04:19:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logwatch conf patch (586 bytes, patch)
2012-03-07 04:09 EST, Jan Synacek
no flags Details | Diff
Logwatch cron patch (496 bytes, patch)
2012-03-07 04:09 EST, Jan Synacek
no flags Details | Diff
Logwatch main script patch (822 bytes, patch)
2012-03-07 04:10 EST, Jan Synacek
no flags Details | Diff

  None (edit)
Description Ed Avis 2009-03-31 10:16:23 EDT
The logwatch package installs /etc/cron.daily/0logwatch which sends a message every day.  One might want to have the package installed, but without this daily cron job, so there should be some way to turn off the cron job.

Just removing the cron.daily/0logwatch file doesn't work because the next package update to logwatch will put it back again.

Please consider this an enhancement request to provide a way for sysadmins to have logwatch installed but without running the cron job daily.

(I understand that the specific suggestion of separating out the 0logwatch file into a separate package was rejected in #479720, but I still think it is important to be able to have logwatch installed without running the job daily, so perhaps there is some other solution to this.)
Comment 1 Allen Kistler 2009-06-23 18:22:22 EDT
(In reply to comment #0)
> Please consider this an enhancement request to provide a way for sysadmins to
> have logwatch installed but without running the cron job daily.

Check out /usr/share/logwatch/default.conf/logwatch.conf, particularly the lines which read:

# if set, the results will be saved in <filename> instead of mailed
# or displayed.
#Save = /tmp/logwatch

Local configuration options then go in /etc/logwatch/conf/logwatch.conf

HTH
Comment 2 Ivana Varekova 2009-06-26 03:08:56 EDT
Fixed in logwatch-7.3.6-44.fc12 (there is added option DailyReport).
Comment 3 Ken Dreyer 2011-10-31 19:17:17 EDT
Did this get wiped out? I don't see this option in F15.
Comment 4 Ken Dreyer 2011-10-31 19:44:41 EDT
The Fedora-specific cron task was wiped in c74780a7 to align with upstream.

When this happened, the DailyReport option in /usr/share/logwatch/default.conf/logwatch.conf disappeared and the check in 0logwatch didn't survive.
Comment 5 Fedora Admin XMLRPC Client 2011-12-16 05:47:35 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Jan Synacek 2012-03-07 04:09:17 EST
Created attachment 568199 [details]
Logwatch conf patch
Comment 7 Jan Synacek 2012-03-07 04:09:44 EST
Created attachment 568200 [details]
Logwatch cron patch
Comment 8 Jan Synacek 2012-03-07 04:10:09 EST
Created attachment 568201 [details]
Logwatch main script patch
Comment 9 Jan Synacek 2012-03-07 04:19:08 EST
Attached some patches implementing the reported enhancement request.

As this change was rejected before, I'm closing this as WONTFIX.
Feel free to use the patches (turning off the cron job may be easier after all).

Note You need to log in before you can comment on or make changes to this bug.