Bug 493110 - Package installation using SSM should only generate one scheduled event.
Package installation using SSM should only generate one scheduled event.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
530
All Linux
low Severity medium
: ---
: ---
Assigned To: Jay Dobies
Sayli Karmarkar
:
Depends On: 443500
Blocks: 456985
  Show dependency treegraph
 
Reported: 2009-03-31 12:51 EDT by Justin Sherrill
Modified: 2009-09-10 16:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 16:34:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2009-03-31 12:51:23 EDT
1.  Select two or more systems for use with the SSM.
2.  Go to the SSM -> packages -> install new package (or upgrade)
3.  Select a package that is applicable to 2 or more systems
4.  Confirm scheduling


Expected: 
One action is scheduled affecting both systems.

Actual:
Two actions are scheduled, one for each system.
Comment 1 Justin Sherrill 2009-03-31 12:51:50 EDT
I believe LVM has complained about this, but I've never seen a BZ for it and I noticed this behaviour the other day.
Comment 2 Clifford Perry 2009-03-31 15:06:57 EDT
bug 444199  &  bug 443500 are others reported on this same topic.
Comment 3 Clifford Perry 2009-03-31 15:12:00 EDT
Based on no more than 2 man days of effort to get working - moving over all 3 bugs that were reported on this topic into 530. 

Cliff.
Comment 4 Jay Dobies 2009-04-08 14:30:08 EDT
Renamed BZ to only refer to install. 444199 handles upgrades.
Comment 5 Jay Dobies 2009-04-08 14:33:46 EDT
Commit: 20353daa6a029c20866985699ba890a0ceaccd21

SchedulePackageInstallationAction.java
ActionManager.java
EnableConfigHelper.java

Changed package installation through SSM to only create one action

Refactored the scheduled action creation to support multiple servers. Changed the SSM package installation calls to use these new multiple-server APIs to result in only one action creation for a batch of servers in the SSM.
Comment 6 Jay Dobies 2009-04-08 14:35:00 EDT
Vader Commit: 80dcaa7236c2bccfd87ff58e1116124b58eccab2
Comment 7 Sayli Karmarkar 2009-04-28 17:22:59 EDT
Jason,

Seems to be working for package installation and removal, but not for verify and upgrade. Is this expected? or is there another bug associated with it? 

~SayliK
Comment 8 Jay Dobies 2009-04-29 09:02:35 EDT
Yes, there were three bugs in total. This one was just for installation. There is also 443500 which is package removal and 444199 for package upgrade. Both are updated to reflect their states. There wasn't a bug for verify filed as far as I saw when I grabbed these three.
Comment 9 Sayli Karmarkar 2009-04-29 11:42:21 EDT
Verified for package installation as per comment #8.
Comment 10 Jan Pazdziora 2009-09-07 07:29:11 EDT
Stage validated with Satellite-5.3.0-RHEL5-re20090820.1. I have registered the system twice, having two system profiles. I have selected both systems, clicked Manage, packages Install, selected Red Hat Enterprise Linux (v. 5 for 32-bit x86), filtered for mutt, selected, clicked Install Selected Packages, seen two systems listed, hit Confirm.

Then I went to Schedule and seen one "Package Install" event, with two In Progress Systems. I've run rhn_check -vv on the system, and one of the profiles moved to Completed Systems.

Moving to RELEASE_PENDING.
Comment 11 Brandon Perkins 2009-09-10 16:34:55 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.