Bug 493134 - diskboot.img fails to get dhcp address on e1000/e1000e
diskboot.img fails to get dhcp address on e1000/e1000e
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda-images (Show other bugs)
5.3
x86_64 Linux
low Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 14:30 EDT by Jesse Brandeburg
Modified: 2009-06-07 21:46 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-07 21:46:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jesse Brandeburg 2009-03-31 14:30:13 EDT
Description of problem:
System fails to achieve dhcp address for network install.



Version-Release number of selected component (if applicable):
RHEL5.3 x86_64/Server/images/diskboot.img

How reproducible:
always


Steps to Reproduce:
When attempting install from usb key with file images/diskboot.img dd'd to it, the installer kernel starts and boots into anaconda just fine.

I select English/us keyboard, select http install, select dhcp for IPv4 only, deselect IPv6, hit next/ok button and the install will not proceed.
  
Actual results:
alt-f3 log shows dhcp failed with message:
dhcp: ioctl SIOCGIFFLAGS failed 19 No such device

nothing I do at this point will make the install continue, including trying a manual address.

Expected results:
network installs should work.

Additional info:
boot.iso also fails in the same way booted off a cd.

tried both e1000 and e1000e hardware

the system is an ICH10 based motherboard
Comment 1 Chris Lumens 2009-05-19 13:35:14 EDT
Can you determine if the kernel module is even loaded?  I would think if you have the option to pick that card, you'd have the module loaded.  You may also get some useful kernel error messages on tty4 or tty5 that could help determine what's going on.
Comment 2 Jesse Brandeburg 2009-05-26 13:07:40 EDT
sorry I've been extremely busy, I hope to get to this this week.
Comment 3 Jesse Brandeburg 2009-06-05 20:20:40 EDT
i386/x86_64 worked fine when I just tried it, the e1000/e1000e drivers were loaded and I got a DHCP address, after booting from usb key.

this was on 82541PI PCI adapter using e1000 driver.

please close as unreproducable, sorry for the thrash.
Comment 4 Chris Lumens 2009-06-07 21:46:05 EDT
Okay, thanks for retesting.

Note You need to log in before you can comment on or make changes to this bug.