Bug 493142 - [RHEL5] libprintbackend-lpr.so does not print until application exits
[RHEL5] libprintbackend-lpr.so does not print until application exits
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gtk2 (Show other bugs)
5.3
All Linux
low Severity medium
: rc
: ---
Assigned To: Benjamin Otte
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 14:51 EDT by Robin R. Price II
Modified: 2014-09-15 09:43 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-02 09:08:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robin R. Price II 2009-03-31 14:51:43 EDT
Description of problem:
The lpr print backend library does not close the file descriptor to the lpr
command promptly.  (cf. GTK+ bug ID #390159,
"(gtk_print_backend_lpr_print_stream): Close the io channel on unref."); see
http://bugzilla.gnome.org/show_bug.cgi?id=390159 for further details.

Version-Release number of selected component (if applicable):
gtk2-2.10.4-20.el5 libprintbackend-lpr.so 
(reproduced using firefox-3.0.6-1.el5)

How reproducible:
Always

Steps to Reproduce:
1. Configure gtk+ to use the lpr backend (e.g., by putting the line gtk-print-backends = "file,lpr" into the user's ~/.gtkrc-2.0 file or one of the system gtkrc files
2. Launch Firefox 3.0.6 ("/usr/bin/firefox")
3. Print a page using the "Print to LPR" option in the print dialog.

  
Actual results:
The page does not print until the browser has been closed; running "ps" displays
that an lpr child process of firefox 3 is still running.

Expected results:
The page should print immediately and the lpr process should not remain.

Additional info:

Same bug as the following but also happens in RHEL5:
https://bugzilla.redhat.com/show_bug.cgi?id=456942
Comment 1 Robin R. Price II 2009-03-31 14:52:50 EDT
If I can get a patch for this, I will spin a RPM for the user to test.

-- Robin
Comment 2 Tim Waugh 2009-03-31 16:20:45 EDT
Fixing assignee.
Comment 5 RHEL Product and Program Management 2014-03-07 08:40:01 EST
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.
Comment 6 RHEL Product and Program Management 2014-06-02 09:08:27 EDT
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).

Note You need to log in before you can comment on or make changes to this bug.