Bug 493154 - (Scribus_RAM_eater) Scribus consumes more RAM while opening some PDF files
Scribus consumes more RAM while opening some PDF files
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: scribus (Show other bugs)
10
All Linux
high Severity high
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-31 15:51 EDT by Luya Tshimbalanga
Modified: 2009-06-21 21:50 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-21 21:50:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File used to open with Scribus (1.14 MB, application/pdf)
2009-03-31 15:51 EDT, Luya Tshimbalanga
no flags Details
Freezing Scribus when opening a PDF file (54.80 KB, image/png)
2009-04-01 14:46 EDT, Luya Tshimbalanga
no flags Details
File test (522.71 KB, application/pdf)
2009-06-13 04:08 EDT, Luya Tshimbalanga
no flags Details

  None (edit)
Description Luya Tshimbalanga 2009-03-31 15:51:49 EDT
Created attachment 337395 [details]
File used to open with Scribus

Description of problem:
Opening some PDF files cause Scribus to consume more RAM (above 3GB) which uses enough to bring 4GB RAM desktop/laptop to their knees. I was unable to capture the problem because I was forced to hard reset.

Version-Release number of selected component (if applicable):
1.3.5svn

How reproducible:
Always

Steps to Reproduce:
1. Download attached PDF file
2. Open with Scribus
3.
  
Actual results:
Cause total freeze of system and RAM consumption exceeded 3GB.

Expected results:
PDF file should be open

Additional info:
Comment 1 Dan Horák 2009-04-01 08:14:48 EDT
Can you try the F-10 rebuild of the package that was recently pushed into rawhide, available at https://koji.fedoraproject.org/koji/taskinfo?taskID=1269801? It is a newer SVN snapshot for the upcoming 1.3.5.
Comment 2 Luya Tshimbalanga 2009-04-01 14:46:22 EDT
Created attachment 337612 [details]
Freezing Scribus when opening a PDF file

Better in term of RAM consumption but the opened/converted PDF slows down for a minutes. Some PDF files render incorrectly.
Comment 3 Dan Horák 2009-04-05 12:38:52 EDT
Well, it's a problem of carrying a snapshot in the distro that was requested by other users ...
Comment 4 Dan Horák 2009-05-21 09:55:34 EDT
Any change when 1.3.5 beta from F-10 updates is used?
Comment 5 Luya Tshimbalanga 2009-06-13 04:08:03 EDT
Created attachment 347720 [details]
File test 

For attachment 337395 [details], converted PDF is blank. I include a new pdf named grand_sport_configurator for a simple text. Text are intact minus the colours and images are missing. Opening a PDF no longer slow down as I tested it on 2GB RAM XNote LT20.
Comment 6 Dan Horák 2009-06-15 02:31:50 EDT
Please open an upstream bug at http://bugs.scribus.net for such functional issues. Unfortunately we (the package maintainers) have not enough knowledge and other resources to dig into this kind of problems.
Comment 7 Luya Tshimbalanga 2009-06-15 17:19:01 EDT
I opened bug on http://bugs.scribus.net/view.php?id=8160 so i suggest to keep track with. This current report can be closed because RA?M issue is no longer the problem.

Note You need to log in before you can comment on or make changes to this bug.