Bug 493163 - Internal Server Errors when editing kickstart distribution
Internal Server Errors when editing kickstart distribution
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
urgent Severity high
: ---
: ---
Assigned To: Justin Sherrill
Sayli Karmarkar
:
Depends On:
Blocks: 457075
  Show dependency treegraph
 
Reported: 2009-03-31 16:12 EDT by Sayli Karmarkar
Modified: 2009-09-10 15:24 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 15:24:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (122.63 KB, image/png)
2009-04-08 12:52 EDT, Sayli Karmarkar
no flags Details

  None (edit)
Description Sayli Karmarkar 2009-03-31 16:12:14 EDT
Steps to Reproduce:
1. Create a kickstart distribution "foobar" 
2. Click on variable and you will be able to access the link and see variables. 
3. Now click on Edit and click on "update kickstart distribution"
  
Actual results:
Internal server error at step 3. 

Expected results:
No ISE
Comment 2 Justin Sherrill 2009-04-02 11:33:00 EDT
this should have been fixed with the commit for this bz:

https://bugzilla.redhat.com/show_bug.cgi?id=462593

tested on my devel box and can no longer reproduce, moving to modified.
Comment 3 Sayli Karmarkar 2009-04-08 12:52:31 EDT
I checked https://bugzilla.redhat.com/show_bug.cgi?id=462593 and it seems to have fixed. However, I am still seeing ISE on updating kickstart distribution, whether we change anything in it or not.
Comment 4 Sayli Karmarkar 2009-04-08 12:52:59 EDT
Created attachment 338757 [details]
screenshot
Comment 5 Justin Sherrill 2009-04-09 12:50:45 EDT
Ah good catch!     It's still getting an ISE on RHEL 4 distros.  The fix:

7a85314
Comment 7 Sayli Karmarkar 2009-04-15 12:39:20 EDT
This doesn't appear to be a problem for newly created orgs, but it seems to reappear for org=1. It seems something is changed from previous iso which has altered the behavior. Moving to fails_qa so that we can resolve this issue.
Comment 8 Sayli Karmarkar 2009-04-15 12:43:24 EDT
Please ignore comment #7. Not related to this bug.
Comment 9 Justin Sherrill 2009-04-16 16:36:35 EDT
205ca44

arg, looks like cobbler 1.6.3 broke some things.
Comment 10 Sayli Karmarkar 2009-04-29 17:21:32 EDT
verified.
Comment 11 Preethi Thomas 2009-07-28 17:34:05 EDT
release pending
https://sun-x4200-01.rhts.bos.redhat.com
no ise with ks-distribution/variables
Comment 12 Brandon Perkins 2009-09-10 15:24:54 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1434.html

Note You need to log in before you can comment on or make changes to this bug.