Bug 493177 - proxy, restarting proxy errors
proxy, restarting proxy errors
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Server (Show other bugs)
530
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Suchý
Tomas Lestach
na
:
Depends On:
Blocks: 456999 463877
  Show dependency treegraph
 
Reported: 2009-03-31 16:55 EDT by wes hayutin
Modified: 2009-09-10 10:38 EDT (History)
3 users (show)

See Also:
Fixed In Version: sat530
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-10 10:38:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wes hayutin 2009-03-31 16:55:28 EDT
Description of problem:
Satellite-5.3.0-RHEL5-re20090327.0-i386-embedded-oracle.iso
x86 rhel 5 proxy server

[root@dhcp77-135 tmp]# /usr/sbin/rhn-proxy restart
Shutting down rhn-proxy...
Stopping MonitoringScout ...  Stopping Dispatcher ...  [ OK ]
Stopping Dequeuer ...  [ OK ]
Stopping SputLite ...  [ OK ]
Stopping NPBootstrap ...  [ OK ]
Stopping InstallSoftwareConfig ...  [ OK ]
[ OK ]
Shutting down Jabber router:                               [  OK  ]
Stopping httpd:                                            [  OK  ]
Stopping squid: .                                          [  OK  ]
Done.
Starting rhn-proxy...
Starting squid: .                                          [  OK  ]
Starting httpd:                                            [  OK  ]
Starting Jabber services                                   [  OK  ]
Starting MonitoringScout ...  Starting InstallSoftwareConfig ...  [ OK ]
Starting NPBootstrap ...  2009-03-31 16:51:36 NPBootstrap:      !! ERROR FROM SHELL COMMAND: 
2009-03-31 16:51:36 NPBootstrap:        !! STDOUT: 
2009-03-31 16:51:36 NPBootstrap:        !! STDERR: Can't load '/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/DBD/Oracle/Oracle.so' for module DBD::Oracle: /usr/lib/oracle/10.2.0.4/client/lib/libnnz10.so: cannot restore segment prot after reloc: Permission denied at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/DynaLoader.pm line 230.
 at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Probe/DataSource/Oracle.pm line 7
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Probe/DataSource/Oracle.pm line 7.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Probe/DataSource/Oracle.pm line 7.
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Probe/DataSource/Factory.pm line 5.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Probe/DataSource/Factory.pm line 5.
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Probe/ProbeRunner.pm line 16.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Probe/ProbeRunner.pm line 16.
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Scheduler/Event/ProbeEvent.pm line 14.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Scheduler/Event/ProbeEvent.pm line 14.
Compilation failed in require at /usr/bin/scheduleEvents line 12.
BEGIN failed--compilation aborted at /usr/bin/scheduleEvents line 12.

2009-03-31 16:51:36 NPBootstrap:        !! EXIT: 512
[ FAIL ]
2009-03-31 16:51:36 NPBootstrap: WARNING: STARTED BUT *NOT* RUNNING
2009-03-31 16:51:36 NPBootstrap: ERRORS ENCOUNTERED DURING LAST ACTION:
2009-03-31 16:51:36 NPBootstrap:        !! ERROR FROM SHELL COMMAND: 
2009-03-31 16:51:36 NPBootstrap:        !! STDOUT: 
2009-03-31 16:51:36 NPBootstrap:        !! STDERR: Can't load '/usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi/auto/DBD/Oracle/Oracle.so' for module DBD::Oracle: /usr/lib/oracle/10.2.0.4/client/lib/libnnz10.so: cannot restore segment prot after reloc: Permission denied at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/DynaLoader.pm line 230.
 at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Probe/DataSource/Oracle.pm line 7
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Probe/DataSource/Oracle.pm line 7.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Probe/DataSource/Oracle.pm line 7.
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Probe/DataSource/Factory.pm line 5.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Probe/DataSource/Factory.pm line 5.
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Probe/ProbeRunner.pm line 16.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Probe/ProbeRunner.pm line 16.
Compilation failed in require at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Scheduler/Event/ProbeEvent.pm line 14.
BEGIN failed--compilation aborted at /usr/lib/perl5/vendor_perl/5.8.8/NOCpulse/Scheduler/Event/ProbeEvent.pm line 14.
Compilation failed in require at /usr/bin/scheduleEvents line 12.
BEGIN failed--compilation aborted at /usr/bin/scheduleEvents line 12.

2009-03-31 16:51:36 NPBootstrap:        !! EXIT: 512
Starting SputLite ...  [ OK ]
Starting Dequeuer ...  [ OK ]
Starting Dispatcher ...  [ OK ]
Comment 1 Miroslav Suchý 2009-05-21 05:47:26 EDT
I can not reproduce it now. It probably duplicate of 493295. Can you test it again? On next iso since current is busted due 499568.
Comment 2 Miroslav Suchý 2009-05-22 07:39:36 EDT
Satellite-5.3.0-RHEL4-re20090521.1 is out 
moving ON_QA
Comment 3 Tomas Lestach 2009-07-02 04:45:48 EDT
# rhn-proxy status
squid (pid 27461) is running...
httpd (pid 27542 27541 27540 27526 27525 27524 27523 27522 27482) is running...
jabberd router (pid 27519) is running...
2009-07-02 10:39:04 MonitoringScout: ----------- InstallSoftwareConfig STATUS ---------------
2009-07-02 10:39:04 MonitoringScout: ----------- NPBootstrap STATUS ---------------
2009-07-02 10:39:04 MonitoringScout: ----------- SputLite STATUS ---------------
2009-07-02 10:39:04 MonitoringScout: ----------- Dequeuer STATUS ---------------
2009-07-02 10:39:04 MonitoringScout: ----------- Dispatcher STATUS ---------------
# rhn-proxy restart
Shutting down rhn-proxy...
Stopping MonitoringScout ...  
	Stopping Dispatcher ...  [ OK ]
	Stopping Dequeuer ...  [ OK ]
	Stopping SputLite ...  [ OK ]
	Stopping NPBootstrap ...  [ OK ]
	Stopping InstallSoftwareConfig ...  [ OK ]
[ OK ]
Shutting down Jabber router:                               [  OK  ]
Stopping httpd:                                            [  OK  ]
Stopping squid: .                                          [  OK  ]
Done.
Starting rhn-proxy...
Starting squid: .                                          [  OK  ]
Starting httpd:                                            [  OK  ]
Starting Jabber services                                   [  OK  ]
Starting MonitoringScout ...  
	Starting InstallSoftwareConfig ...  [ OK ]
	Starting NPBootstrap ...  [ OK ]
	Starting SputLite ...  [ OK ]
	Starting Dequeuer ...  [ OK ]
	Starting Dispatcher ...  [ OK ]
[ OK ]
Done.
# rhn-proxy status
squid (pid 27775) is running...
httpd (pid 27843 27842 27841 27840 27817 27816 27815 27814 27796) is running...
jabberd router (pid 27837) is running...
2009-07-02 10:40:11 MonitoringScout: ----------- InstallSoftwareConfig STATUS ---------------
2009-07-02 10:40:11 MonitoringScout: ----------- NPBootstrap STATUS ---------------
2009-07-02 10:40:12 MonitoringScout: ----------- SputLite STATUS ---------------
2009-07-02 10:40:12 MonitoringScout: ----------- Dequeuer STATUS ---------------
2009-07-02 10:40:12 MonitoringScout: ----------- Dispatcher STATUS ---------------

RHN Proxy 5.3.0 restarts without problems.

Verified with following proxy version:
# rpm -qa | grep proxy
spacewalk-proxy-redirect-0.5.7-7.el5sat
spacewalk-proxy-management-0.5.7-7.el5sat
spacewalk-proxy-package-manager-0.5.7-7.el5sat
spacewalk-proxy-selinux-0.5.2-6.el5sat
rhn-proxy-branding-5.3.0.24-1.el5sat
spacewalk-proxy-docs-0.4.1-2.el5sat
spacewalk-proxy-monitoring-0.4.4-3.el5sat
spacewalk-proxy-common-0.5.7-7.el5sat
spacewalk-proxy-broker-0.5.7-7.el5sat
Comment 4 Jan Pazdziora 2009-09-08 10:16:56 EDT
Stage validated with RHN Proxy 5.3.0 GA:

[root@vmware139 rhn]# rpm -qa | grep proxy
spacewalk-proxy-common-0.5.7-10.el5sat
spacewalk-proxy-docs-0.4.1-2.el5sat
spacewalk-proxy-monitoring-0.4.4-4.el5sat
spacewalk-proxy-broker-0.5.7-10.el5sat
spacewalk-proxy-management-0.5.7-10.el5sat
spacewalk-proxy-package-manager-0.5.7-10.el5sat
spacewalk-proxy-redirect-0.5.7-10.el5sat
rhn-proxy-branding-5.3.0.27-1.el5sat
spacewalk-proxy-selinux-0.5.2-7.el5sat
[root@vmware139 rhn]# /usr/sbin/rhn-proxy restart
Shutting down rhn-proxy...
Stopping MonitoringScout ...  
	Stopping Dispatcher ...  [ OK ]
	Stopping Dequeuer ...  [ OK ]
	Stopping SputLite ...  [ OK ]
	Stopping NPBootstrap ...  [ OK ]
	Stopping InstallSoftwareConfig ...  [ OK ]
[ OK ]
Shutting down Jabber router:                               [  OK  ]
Stopping httpd:                                            [  OK  ]
Stopping squid: .                                          [  OK  ]
Done.
Starting rhn-proxy...
Starting squid: .                                          [  OK  ]
Starting httpd:                                            [  OK  ]
Starting Jabber services                                   [  OK  ]
Starting MonitoringScout ...  
	Starting InstallSoftwareConfig ...  [ OK ]
	Starting NPBootstrap ...  [ OK ]
	Starting SputLite ...  [ OK ]
	Starting Dequeuer ...  [ OK ]
	Starting Dispatcher ...  [ OK ]
[ OK ]
Done.
[root@vmware139 rhn]#

Moving to RELEASE_PENDING.
Comment 5 Brandon Perkins 2009-09-10 10:38:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2009-1433.html

Note You need to log in before you can comment on or make changes to this bug.