Bug 493257 - Anaconda fails with encrypted device when choosing to skip entering password
Anaconda fails with encrypted device when choosing to skip entering password
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:720a395bd91f80adb...
:
: 493298 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 02:11 EDT by Alexey Torkhov
Modified: 2009-04-09 09:48 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-09 09:48:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (73.65 KB, text/plain)
2009-04-01 02:11 EDT, Alexey Torkhov
no flags Details
Attached traceback automatically from anaconda. (105.61 KB, text/plain)
2009-04-01 10:42 EDT, Ben Lambrechts
no flags Details
Attached traceback automatically from anaconda. (108.97 KB, text/plain)
2009-04-08 22:32 EDT, Matt
no flags Details

  None (edit)
Description Alexey Torkhov 2009-04-01 02:11:25 EDT
The following was filed automatically by anaconda:
anaconda 11.5.0.38 exception report
Traceback (most recent call first):
  File "/usr/lib/anaconda/storage/devicetree.py", line 690, in _removeDevice
    raise ValueError("Cannot remove non-leaf device '%s'" % dev.name)
  File "/usr/lib/anaconda/storage/devicetree.py", line 731, in registerAction
    self._removeDevice(action.device)
  File "/usr/lib/anaconda/storage/__init__.py", line 166, in undoEncryption
    storage.devicetree.registerAction(ActionDestroyDevice(device))
  File "/usr/lib/anaconda/storage/__init__.py", line 139, in storageComplete
    undoEncryption(anaconda.id.storage)
  File "/usr/lib/anaconda/dispatch.py", line 205, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 128, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1317, in nextClicked
    self.anaconda.dispatch.gotoNext()
ValueError: Cannot remove non-leaf device 'luks-vda2'
Comment 1 Alexey Torkhov 2009-04-01 02:11:32 EDT
Created attachment 337444 [details]
Attached traceback automatically from anaconda.
Comment 2 Ben Lambrechts 2009-04-01 10:42:32 EDT
Created attachment 337546 [details]
Attached traceback automatically from anaconda.
Comment 3 Chris Lumens 2009-04-01 10:59:22 EDT
*** Bug 493298 has been marked as a duplicate of this bug. ***
Comment 4 Matt 2009-04-08 22:32:19 EDT
Created attachment 338834 [details]
Attached traceback automatically from anaconda.
Comment 5 David Lehman 2009-04-09 09:48:02 EDT
This is fixed in anaconda-11.5.0.41-1 (in rawhide). Thanks for the bug report.

Note You need to log in before you can comment on or make changes to this bug.